summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2023-09-18 10:57:56 +0100
committerSimon McVittie <smcv@debian.org>2023-09-18 10:57:56 +0100
commit61b474912c6d39cdb6028da1bf854675c717819c (patch)
tree86a05b0bda2ab540b2814ccfe19754723d069f29
parent4c040846f7b9b992bc6e35b5382ad3733abadc11 (diff)
Add proposed patch to remove unnecessary python3-nose runtime dependency
-rw-r--r--debian/patches/pyproject.toml-Move-nose-from-dependencies-to-dev-depende.patch30
-rw-r--r--debian/patches/series1
2 files changed, 31 insertions, 0 deletions
diff --git a/debian/patches/pyproject.toml-Move-nose-from-dependencies-to-dev-depende.patch b/debian/patches/pyproject.toml-Move-nose-from-dependencies-to-dev-depende.patch
new file mode 100644
index 0000000..d413d94
--- /dev/null
+++ b/debian/patches/pyproject.toml-Move-nose-from-dependencies-to-dev-depende.patch
@@ -0,0 +1,30 @@
+From: Simon McVittie <smcv@debian.org>
+Date: Mon, 18 Sep 2023 10:36:12 +0100
+Subject: pyproject.toml: Move nose from dependencies to dev-dependencies
+
+This is only needed when running the build-time tests, and is not needed
+for ordinary use of the tool.
+
+Signed-off-by: Simon McVittie <smcv@debian.org>
+Forwarded: https://github.com/intel/bmap-tools/pull/120
+---
+ pyproject.toml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 502ad3e..5953fd8 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -8,11 +8,11 @@ authors = ["Artem Bityutskiy <dedekind1@gmail.com>"]
+ [tool.poetry.dependencies]
+ python = "^3.8"
+ six = "^1.16.0"
+-nose = "^1.3.7"
+ gpg = "^1.10.0"
+
+ [tool.poetry.dev-dependencies]
+ black = "^22.3.0"
++nose = "^1.3.7"
+
+ [tool.poetry.scripts]
+ bmaptool = "bmaptools.CLI:main"
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..6efb61a
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+pyproject.toml-Move-nose-from-dependencies-to-dev-depende.patch