summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklas Kunz <git@monoton.space>2022-06-26 16:11:33 +0200
committerGitHub <noreply@github.com>2022-06-26 16:11:33 +0200
commitb7e09e632f185245ff4370e60e07aa93754caa07 (patch)
treeaa073e5a3a99ef88d9af89ad0e69c856ddf30cc2
parent22570ca48d257a3ed2f5ff4d54ff00d33aff569b (diff)
parent610ffe652d7d1f9963efed5aa9b0c59177ff45e2 (diff)
Merge pull request #109 from mntns/gh-actions
Add basic GitHub Actions workflow
-rw-r--r--.github/workflows/ci.yml44
-rw-r--r--.travis.yml37
2 files changed, 44 insertions, 37 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
new file mode 100644
index 0000000..e3adc8f
--- /dev/null
+++ b/.github/workflows/ci.yml
@@ -0,0 +1,44 @@
+name: ci
+
+on:
+ push:
+ branches: [ "master" ]
+ pull_request:
+ branches: [ "master" ]
+
+jobs:
+ check:
+ runs-on: ubuntu-latest
+
+ steps:
+ - uses: actions/checkout@v3
+ - name: Set up Python
+ uses: actions/setup-python@v3
+ with:
+ python-version: '3.x'
+ - name: Install black
+ run: pip install black
+ - name: Check code
+ run: black bmaptools/* tests/* --check
+
+ test:
+ needs: check
+ runs-on: ubuntu-latest
+ strategy:
+ fail-fast: false
+ matrix:
+ python-version: ["3.8", "3.9", "3.10"]
+
+ steps:
+ - uses: actions/checkout@v3
+ - name: Set up Python ${{ matrix.python-version }}
+ uses: actions/setup-python@v3
+ with:
+ python-version: ${{ matrix.python-version }}
+ - name: Install dependencies
+ run: |
+ # Installs compression deps
+ sudo apt-get install -y pbzip2 pigz lzop liblz4-tool
+ # Installs poetry
+ curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/get-poetry.py | python -
+ poetry install
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 5d79525..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,37 +0,0 @@
-language: python
-python:
- - "2.7"
- - "3.3"
- - "3.4"
- - "3.5"
- - "3.6"
- - "3.7"
- - "3.9"
-# pypy 2.x currently disabled, until testing fixed.
-# - "pypy"
-# - "pypy3"
-# command to install dependencies
-install:
- - pip install codecov backports.tempfile mock
- - pip install .
-# command to run tests
-script: python setup.py nosetests --with-coverage --cover-xml
-after_success:
- - codecov
-# Don't bug people yet
-notifications:
- email: false
-
-# Perform testing also using optional compressors
-sudo: required
-dist: trusty
-before_install:
- - sudo apt-get -qq update
- - sudo apt-get install -y pbzip2 pigz lzop liblz4-tool
-# addons:
-# apt:
-# packages:
-# - pbzip2
-# - pigz
-# - lzop
-# - liblz4-tool