summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2023-01-14 08:34:46 +0100
committerHelmut Grohne <helmut@subdivi.de>2023-01-14 08:34:46 +0100
commit419784f27da33441090b66a7e1d29780321370e6 (patch)
tree94bbb9ee71da73baf23b78e1aea306d9fb347b70
parentccff1416aea263df72343da4adf4e09dc8e3a74f (diff)
Rebuild documentation from source
Documentation sources are no longer built during the extension build. Instead, there is a build_usage and build_man setup.py command.
-rwxr-xr-xdebian/rules12
1 files changed, 6 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 662c33db..27b7f69a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -44,15 +44,15 @@ export PYBUILD_TEST_ARGS=\
override_dh_auto_configure:
dh_auto_configure -- --install-dir=$(MODULE_DIR)
-override_dh_installdocs:
- python3 setup.py build_ext --inplace
+execute_after_dh_auto_build:
+ PYTHONPATH=$(wildcard ./.pybuild/*/build) python3 setup.py build_usage
+ PYTHONPATH=$(wildcard ./.pybuild/*/build) python3 setup.py build_man
+
+execute_before_dh_installdocs-indep:
$(MAKE) -C docs html
- dh_installdocs
-override_dh_installman:
- python3 setup.py build_ext --inplace
+execute_before_dh_installman-arch:
$(MAKE) -C docs man
- dh_installman
#override_dh_auto_install:
# dh_auto_install