summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2023-01-14 08:15:13 +0100
committerHelmut Grohne <helmut@subdivi.de>2023-01-14 08:15:13 +0100
commit4d3220f78421a4f97ca83118a9ac08f0bd6bb6c7 (patch)
tree71d48523bffa42d590ada440be94870f7243a7bb
parent84ca755e420e2f59d8060b7d4aabce575a178891 (diff)
Stop forcing a SPHINXBUILD
Debian has moved to python3-only and we can just use the standard one
-rwxr-xr-xdebian/rules8
1 files changed, 2 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 17f65726..967ea14e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,10 +2,6 @@
#export DH_VERBOSE=1
-# The command 'sphinx-build' refers to the python2 version;
-# currently there is no easier way to refer to the python3 version.
-SPHINXBUILD=/usr/share/sphinx/scripts/python3/sphinx-build
-
# Full hardening for the cython build.
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
@@ -48,12 +44,12 @@ override_dh_clean:
override_dh_installdocs:
python3 setup.py build_ext --inplace
- $(MAKE) -C docs html SPHINXBUILD=$(SPHINXBUILD)
+ $(MAKE) -C docs html
dh_installdocs
override_dh_installman:
python3 setup.py build_ext --inplace
- $(MAKE) -C docs man SPHINXBUILD=$(SPHINXBUILD)
+ $(MAKE) -C docs man
dh_installman
#override_dh_auto_install: