summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2009-01-22 10:34:46 +0100
committerReinhard Tartler <siretart@tauware.de>2009-01-22 10:34:46 +0100
commit61aa47a8817edfe18a433a3c66f8d25566ca0a01 (patch)
tree158cdc011aaf1246b4a259544e44407726acc522
parent6f08df2e6d6f983be6fe8a5b6b22acc146a89876 (diff)
include in DebugMemLeakFinder.cpp didn't work, let's try
definung MEMLEAKFINDER_FULL_MALLOC_MONITORING
-rw-r--r--debian/changelog3
-rw-r--r--lib/common/DebugMemLeakFinder.cpp5
-rw-r--r--lib/common/MemLeakFinder.h2
3 files changed, 5 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 4c08d2ec..767147dd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,7 +2,8 @@ boxbackup (0.11~rc2-5) unstable; urgency=low
* Bugfix: "Please build-depend on docbook-xml". Thanks to Luca Falavigna
<dktrkranz@ubuntu.com> for reporting. Closes: #507973
- * Add missing includes in lib/common/Logging.cpp and
+ * Add missing #include in lib/common/Logging.cpp. define
+ MEMLEAKFINDER_FULL_MALLOC_MONITORING in
lib/common/DebugMemLeakFinder.cpp. Closes: #505696, #512510
-- Reinhard Tartler <siretart@tauware.de> Thu, 22 Jan 2009 08:26:24 +0100
diff --git a/lib/common/DebugMemLeakFinder.cpp b/lib/common/DebugMemLeakFinder.cpp
index 625dfd4d..501748b8 100644
--- a/lib/common/DebugMemLeakFinder.cpp
+++ b/lib/common/DebugMemLeakFinder.cpp
@@ -64,10 +64,9 @@
#include <string.h>
#include <set>
-#include "MemLeakFinder.h"
-
// c.f. http://bugs.debian.org/512510
-#include <cstdlib>
+#define MEMLEAKFINDER_FULL_MALLOC_MONITORING 1
+#include "MemLeakFinder.h"
static bool memleakfinder_initialised = false;
bool memleakfinder_global_enable = false;
diff --git a/lib/common/MemLeakFinder.h b/lib/common/MemLeakFinder.h
index 7fc53033..3bcfc37b 100644
--- a/lib/common/MemLeakFinder.h
+++ b/lib/common/MemLeakFinder.h
@@ -51,7 +51,7 @@
#ifdef MEMLEAKFINDER_FULL_MALLOC_MONITORING
// include stdlib now, to avoid problems with having the macros defined already
- #include <stdlib.h>
+ #include <cstdlib>
#endif
// global enable flag