summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2009-01-22 08:32:50 +0100
committerReinhard Tartler <siretart@tauware.de>2009-01-22 08:32:50 +0100
commit6f08df2e6d6f983be6fe8a5b6b22acc146a89876 (patch)
tree119cb32019e72261e2c1172f2e700a1a0fe8cc17
parent4b622442efc5f5f53e571f55f2ae8fd870bc25f1 (diff)
Add missing includes in lib/common/Logging.cpp and
lib/common/DebugMemLeakFinder.cpp. Closes: #505696, #512510
-rw-r--r--debian/changelog2
-rw-r--r--lib/common/DebugMemLeakFinder.cpp3
-rw-r--r--lib/common/Logging.cpp3
3 files changed, 8 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 360aa43d..4c08d2ec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ boxbackup (0.11~rc2-5) unstable; urgency=low
* Bugfix: "Please build-depend on docbook-xml". Thanks to Luca Falavigna
<dktrkranz@ubuntu.com> for reporting. Closes: #507973
+ * Add missing includes in lib/common/Logging.cpp and
+ lib/common/DebugMemLeakFinder.cpp. Closes: #505696, #512510
-- Reinhard Tartler <siretart@tauware.de> Thu, 22 Jan 2009 08:26:24 +0100
diff --git a/lib/common/DebugMemLeakFinder.cpp b/lib/common/DebugMemLeakFinder.cpp
index ea5cbea9..625dfd4d 100644
--- a/lib/common/DebugMemLeakFinder.cpp
+++ b/lib/common/DebugMemLeakFinder.cpp
@@ -66,6 +66,9 @@
#include "MemLeakFinder.h"
+// c.f. http://bugs.debian.org/512510
+#include <cstdlib>
+
static bool memleakfinder_initialised = false;
bool memleakfinder_global_enable = false;
diff --git a/lib/common/Logging.cpp b/lib/common/Logging.cpp
index 383f44cc..a5ffdbae 100644
--- a/lib/common/Logging.cpp
+++ b/lib/common/Logging.cpp
@@ -52,6 +52,9 @@
#include <time.h>
#include <string.h> // for stderror
+// c.f. http://bugs.debian.org/512510
+#include <cstdio>
+
#ifdef HAVE_SYSLOG_H
#include <syslog.h>
#endif