summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2011-01-08 21:01:49 +0000
committerChris Wilson <chris+github@qwirx.com>2011-01-08 21:01:49 +0000
commit24d88d1bcbe740c230c6ddace0ef982b579e6af8 (patch)
tree0663260b4b003bfa27120382cbe4d09fb2c45751
parent6054f0dba8f1ca19ac5cd6eb9b50a5ba6782b099 (diff)
Log more useful information when makebuildenv.pl fails.
Fix hang waiting for console input at the end of ./configure on some shells. (merges [2823])
-rw-r--r--configure.ac2
-rwxr-xr-xinfrastructure/makebuildenv.pl.in6
2 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dff3f9e5..441a869f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -403,7 +403,7 @@ cat parcels.txt | sed -e 's/#.*//' | while read cmd subdir configure_args; do
done || exit $?
# Write summary of important info
-cat | tee config.log.features <<EOC
+tee config.log.features <<EOC
A summary of the build configuration is below. Box Backup will function
without these features, but will work better where they are present. Refer
to the documentation for more information on each feature.
diff --git a/infrastructure/makebuildenv.pl.in b/infrastructure/makebuildenv.pl.in
index f165accc..93115514 100755
--- a/infrastructure/makebuildenv.pl.in
+++ b/infrastructure/makebuildenv.pl.in
@@ -98,7 +98,11 @@ while(<FINDAUTOGEN>)
}
# run command
- die "Couldn't run command $c" unless (0 == system("(cd $dir; $c)"))
+ unless (0 == system("(cd $dir; $c)"))
+ {
+ die "Couldn't run command $c " .
+ "(in $dir) for $file";
+ }
}
}
}