summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2005-12-28 14:04:35 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2005-12-28 14:04:35 +0000
commit96036bf8d4377d8a7e1f7d5587d7df2ed5f73d2b (patch)
tree77cbf62c031838f4204d6ee7e956040e675e837c
parent63c7a6dba860c8c83bde62eee0ac7088cebd3885 (diff)
Fix make distribution
-rw-r--r--distribution/COMMON-MANIFEST.txt13
-rw-r--r--distribution/boxbackup/DISTRIBUTION-MANIFEST.txt2
-rwxr-xr-xinfrastructure/makedistribution.pl8
3 files changed, 17 insertions, 6 deletions
diff --git a/distribution/COMMON-MANIFEST.txt b/distribution/COMMON-MANIFEST.txt
index 5f734964..575cb9f9 100644
--- a/distribution/COMMON-MANIFEST.txt
+++ b/distribution/COMMON-MANIFEST.txt
@@ -15,10 +15,15 @@ docs/common/lib_server notes/lib_server
MKDIR infrastructure
infrastructure/buildenv-testmain-template.cpp
infrastructure/makebuildenv.pl
-infrastructure/BoxPlatform.pm
+infrastructure/BoxPlatform.pm.in
infrastructure/makeparcels.pl
-MKDIR infrastructure/tests
-infrastructure/tests/common_tests.pl
+configure.ac
+NO-LICENSE config.sub
+config.sub
+NO-LICENSE config.guess
+config.guess
+bootstrap
parcels.txt
-configure
runtest.pl
+NO-LICENSE-IN-DIR infrastructure/m4
+infrastructure/m4
diff --git a/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt b/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt
index 72b3866d..1c641005 100644
--- a/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt
+++ b/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt
@@ -3,9 +3,11 @@ test/raidfile
test/raidfile/testfiles
lib/backupclient
lib/backupstore
+lib/win32
bin/bbstored
bin/bbstoreaccounts
bin/bbackupd
+bin/bbackupd/win32
bin/bbackupquery
bin/bbackupctl
bin/bbackupobjdump
diff --git a/infrastructure/makedistribution.pl b/infrastructure/makedistribution.pl
index 712b068c..669f5de6 100755
--- a/infrastructure/makedistribution.pl
+++ b/infrastructure/makedistribution.pl
@@ -78,6 +78,10 @@ sub copy_from_list
{
replace_version_in($dst);
}
+ elsif($src eq 'NO-LICENSE')
+ {
+ $no_license{$dst} = 1;
+ }
elsif(-d $src)
{
$modules_included{$_} = 1;
@@ -205,8 +209,8 @@ sub copy_file
}
}
- # make sure perl scripts are marked as executable, and other things aren't
- if($ext eq 'pl' || $ext eq '')
+ # copy executable bit from src
+ if(-x $fn)
{
system 'chmod','a+x',"$base_name/$dst_fn"
}