summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIleana Dumitrescu <ileanadumi95@protonmail.com>2022-04-07 17:32:43 +0300
committerIleana Dumitrescu <ileanadumi95@protonmail.com>2022-04-07 17:32:43 +0300
commita17cd62d745c7db340a15d24617a15753814bba7 (patch)
tree64abb393e95513dd8230aa3477ec29e436b96efc
parent953ba1e7023142873b4537469292002944db583f (diff)
refreshed patches
-rw-r--r--debian/patches/03-adjust-syslog-facility.diff14
-rw-r--r--debian/patches/05-dont_use_net_for_docs.diff4
2 files changed, 6 insertions, 12 deletions
diff --git a/debian/patches/03-adjust-syslog-facility.diff b/debian/patches/03-adjust-syslog-facility.diff
index 8a02cce2..4359f820 100644
--- a/debian/patches/03-adjust-syslog-facility.diff
+++ b/debian/patches/03-adjust-syslog-facility.diff
@@ -8,11 +8,9 @@ Subject: change default syslog facility from LOG_LOCAL6 to LOG_DAEMON
lib/common/Logging.cpp | 6 +++---
3 files changed, 10 insertions(+), 4 deletions(-)
-diff --git a/docs/docbook/adminguide.xml b/docs/docbook/adminguide.xml
-index edb0a58..440c7d4 100644
--- a/docs/docbook/adminguide.xml
+++ b/docs/docbook/adminguide.xml
-@@ -286,6 +286,12 @@ local5.info /var/log/raidfile</programlisting>
+@@ -286,6 +286,12 @@
<para><emphasis role="bold">Note:</emphasis> Separators must be tabs,
otherwise these entries will be ignored.</para>
@@ -25,11 +23,9 @@ index edb0a58..440c7d4 100644
<programlisting>touch /var/log/box
touch /var/log/raidfile</programlisting>
-diff --git a/lib/bbstored/BackupStoreDaemon.cpp b/lib/bbstored/BackupStoreDaemon.cpp
-index 8fddf12..37b0a6f 100644
--- a/lib/bbstored/BackupStoreDaemon.cpp
+++ b/lib/bbstored/BackupStoreDaemon.cpp
-@@ -203,7 +203,7 @@ void BackupStoreDaemon::Run()
+@@ -203,7 +203,7 @@
SetProcessTitle("housekeeping, idle");
whichSocket = 1;
// Change the log name
@@ -38,11 +34,9 @@ index 8fddf12..37b0a6f 100644
// Log that housekeeping started
BOX_INFO("Housekeeping process started");
// Ignore term and hup
-diff --git a/lib/common/Logging.cpp b/lib/common/Logging.cpp
-index 0928a4d..1cff176 100644
--- a/lib/common/Logging.cpp
+++ b/lib/common/Logging.cpp
-@@ -411,7 +411,7 @@ bool Syslog::Log(Log::Level level, const std::string& file, int line,
+@@ -411,7 +411,7 @@
return true;
}
@@ -51,7 +45,7 @@ index 0928a4d..1cff176 100644
{
::openlog("Box Backup", LOG_PID, mFacility);
}
-@@ -454,8 +454,8 @@ int Syslog::GetNamedFacility(const std::string& rFacility)
+@@ -454,8 +454,8 @@
#undef CASE_RETURN
BOX_ERROR("Unknown log facility '" << rFacility << "', "
diff --git a/debian/patches/05-dont_use_net_for_docs.diff b/debian/patches/05-dont_use_net_for_docs.diff
index 47ac5652..ac02a5aa 100644
--- a/debian/patches/05-dont_use_net_for_docs.diff
+++ b/debian/patches/05-dont_use_net_for_docs.diff
@@ -7,9 +7,9 @@ Forwarded: no
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -10,7 +10,7 @@
-
+
all: docs
-
+
-DBPROC_COMMAND = xsltproc
+DBPROC_COMMAND = xsltproc --nonet
MKDIR_COMMAND = mkdir