summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2018-02-20 21:55:49 -0500
committerReinhard Tartler <siretart@tauware.de>2018-02-20 21:58:04 -0500
commit1ff570990914769be07b3ed3270549c4115b08ee (patch)
tree7a0a74f429c0f53dbe3fc814ecd98b620140051f
parent1d5ea152ea8c64767f4f980fba5049dd456280d0 (diff)
Fix detection logic for tune2fs
* debian/boxbackup-server.config: Fix quoting of variables primarily fixing the logic that handles when tune2fs is not available. * Have boxbackup-server package Recommend e2fsprogs since the package configuration (optionally) uses tune2fs in some cases. (Closes: #887274)
-rw-r--r--debian/boxbackup-server.config19
-rw-r--r--debian/changelog12
-rw-r--r--debian/control1
3 files changed, 20 insertions, 12 deletions
diff --git a/debian/boxbackup-server.config b/debian/boxbackup-server.config
index d722d7d7..d9c07299 100644
--- a/debian/boxbackup-server.config
+++ b/debian/boxbackup-server.config
@@ -32,14 +32,14 @@ while [ $RAIDOK = 0 ]; do
DIR2=`echo "$RET" | awk '{ print $2 }'`
DIR3=`echo "$RET" | awk '{ print $3 }'`
- if [ -n $DIR1 ]; then
+ if [ -n "$DIR1" ]; then
if [ -z "$DIR2" -o -z "$DIR3" ]; then
- DIR2=$DIR1
- DIR3=$DIR1
+ DIR2="$DIR1"
+ DIR3="$DIR1"
fi
PATHOK=1
- for i in $DIR1 $DIR2 $DIR3; do
+ for i in "$DIR1" "$DIR2" "$DIR3"; do
if [ `echo $i | awk '{ if (/^\/[A-Za-z0-9\.\-_]+\/?([A-Za-z0-9\.\-_]+\/?)*$/) { print 1 } else { print 0 } }'` = 0 ]; then
PATHOK=0
fi
@@ -60,13 +60,13 @@ done
# Try to figure out the block size of the first partition given
db_get boxbackup-server/raidDirectories
if [ "$OLDRAIDDIR" != "$RET" ]; then # Directories have been changed so we can try to guess the block size
- TMPDIR=`echo $DIR1 | sed 's/\/$//'`
+ TMPDIR=`echo "$DIR1" | sed 's/\/$//'`
while [ "$TMPDIR" != "" ]; do
DEV=`df -P | grep "$TMPDIR$" | awk '{ print $1 }'`
if [ -z "$DEV" ]; then
- TMPDIR=`echo $TMPDIR | sed 's/\/[^\/]*$//'`
+ TMPDIR=`echo "$TMPDIR" | sed 's/\/[^\/]*$//'`
else
TMPDIR=""
fi
@@ -74,10 +74,10 @@ if [ "$OLDRAIDDIR" != "$RET" ]; then # Directories have been changed so we can t
if [ "$DEV" != "" ]; then
TUNE2FS="$(command -v tune2fs)"
- if [ -x ${TUNE2FS} ]; then
+ if [ -x "${TUNE2FS}" ]; then
BS=`${TUNE2FS} -l $DEV 2>/dev/null | grep 'Block size' | awk '{print $3 }'`
- if [ $? = 0 -a $BS != "" ]; then
+ if [ $? = 0 -a "$BS" != "" ]; then
db_set boxbackup-server/raidBlockSize "$BS"
fi
fi
@@ -97,7 +97,7 @@ while [ $BSOK = 0 ]; do
fi
fi
- if [ $BSOK = 0 ]; then
+ if [ "$BSOK" = 0 ]; then
db_input critical boxbackup-server/incorrectBlocksize || true
db_go
fi
@@ -108,4 +108,3 @@ db_input medium boxbackup-server/generateCertificate || true
db_go
exit 0
-
diff --git a/debian/changelog b/debian/changelog
index 4c220711..ba2f03c7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,18 @@
boxbackup (0.13~~git20180102.g6d7e9562-1) unstable; urgency=medium
- * QA upload
+ [ Andreas Henriksson ]
+ * QA upload.
+ * debian/boxbackup-server.config: Fix quoting of variables primarily
+ fixing the logic that handles when tune2fs is not available.
+ * Have boxbackup-server package Recommend e2fsprogs since the
+ package configuration (optionally) uses tune2fs in some cases.
+ (Closes: #887274)
+
+ [ Reinhard Tartler ]
* New upstream pre-release (requested by upstream)
* Migrate to libssl 1.1 (Closes: #870775)
- -- Reinhard Tartler <siretart@tauware.de> Sat, 13 Jan 2018 20:58:21 -0500
+ -- Reinhard Tartler <siretart@tauware.de> Tue, 20 Feb 2018 21:53:32 -0500
boxbackup (0.12~gitcf52058f-3) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index ef607aaa..c0a16cd5 100644
--- a/debian/control
+++ b/debian/control
@@ -33,6 +33,7 @@ Depends:
ucf,
${misc:Depends},
${shlibs:Depends}
+Recommends: e2fsprogs
Description: server for the BoxBackup remote backup system
BoxBackup is an automatic on-line backup system.
The server waits for connections from remote clients,