summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2017-07-03 18:29:53 +0100
committerChris Wilson <chris+github@qwirx.com>2017-09-16 20:51:27 +0100
commit796d758eef318c012fde12c8aacac671934fb8e9 (patch)
treee03befab43364812207bcca606047bd3a4d62f49
parent75190f42eac277e5b936c60fde6ed4274a9e740c (diff)
Reduce AppVeyor build verbosity by passing extra args to sub-CMake
(cherry picked from commit 4876a5573a8bcd3312e9804c27fe9f30f3369747)
-rw-r--r--appveyor.yml2
-rw-r--r--infrastructure/cmake/windows/CMakeLists.txt5
2 files changed, 5 insertions, 2 deletions
diff --git a/appveyor.yml b/appveyor.yml
index f4dac271..89651f6d 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -58,9 +58,11 @@ install:
# the current PATH.
- echo cmake -G "%generator_name%" -DDEBUG=1
-DBOXBACKUP_VERSION=%compiled_version%
+ -DSUB_CMAKE_EXTRA_ARGS="-- /verbosity:minimal"
%APPVEYOR_BUILD_FOLDER%\infrastructure\cmake\windows
- cmake -G "%generator_name%" -DDEBUG=1
-DBOXBACKUP_VERSION=%compiled_version%
+ -DSUB_CMAKE_EXTRA_ARGS="-- /verbosity:minimal"
%APPVEYOR_BUILD_FOLDER%\infrastructure\cmake\windows
# Leave the current directory in the correct place to find the solution file using its relative path above.
diff --git a/infrastructure/cmake/windows/CMakeLists.txt b/infrastructure/cmake/windows/CMakeLists.txt
index a6d93ee8..1c88472e 100644
--- a/infrastructure/cmake/windows/CMakeLists.txt
+++ b/infrastructure/cmake/windows/CMakeLists.txt
@@ -35,7 +35,7 @@ ExternalProject_Add(zlib
URL "http://zlib.net/zlib-${ZLIB_VERSION}.tar.gz"
URL_HASH ${ZLIB_HASH}
DOWNLOAD_NO_PROGRESS 1
- CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${install_dir}
+ CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${install_dir} ${SUB_CMAKE_EXTRA_ARGS}
# We need to build both versions, debug and release, because cmake requires both to be
# present to generate its multi-configuration project files for Visual Studio/MSBuild.
INSTALL_COMMAND ${CMAKE_COMMAND} --build <BINARY_DIR> --target install --config Debug
@@ -86,7 +86,7 @@ ExternalProject_Add(pcre
SVN_REPOSITORY svn://vcs.exim.org/pcre/code/trunk
SVN_REVISION -r 1677
DOWNLOAD_NO_PROGRESS 1
- CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${install_dir}
+ CMAKE_ARGS -DCMAKE_INSTALL_PREFIX=${install_dir} ${SUB_CMAKE_EXTRA_ARGS}
-DPCRE_SUPPORT_LIBREADLINE=OFF
-DPCRE_SUPPORT_LIBBZ2=OFF
# We need to build both versions, debug and release, because cmake requires both to be
@@ -122,5 +122,6 @@ ExternalProject_Add(boxbackup
-DAPPVEYOR_MODE=1
-DDEBUG=${DEBUG}
${boxbackup_cmake_args}
+ ${SUB_CMAKE_EXTRA_ARGS}
STEP_TARGETS configure build install
)