summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2007-12-13 00:18:45 +0000
committerChris Wilson <chris+github@qwirx.com>2007-12-13 00:18:45 +0000
commit4d11f4b70d988c93d06f396a41de5c92ccf64f65 (patch)
tree8410014503768eec9a5c7d07228581513055e73c
parentea8cc3daba44019769b42299cb49a9474eaf6726 (diff)
Include the header file where dirfd() is supposed to be defined,
otherwise we can expect not to find it and cause problems later with our own definition.
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 46f77f7b..a54690d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,7 +168,10 @@ AC_CHECK_DECLS([optreset],,, [[#include <getopt.h>]])
AC_CHECK_DECL([dirfd],
[],
AC_DEFINE([dirfd(x)], [(x)->d_fd], [dirfd() replacement for Solaris]),
- [#include <getopt.h>])
+ [
+ #include <getopt.h>
+ #include <dirent.h>
+ ])
AC_HEADER_TIME
AC_STRUCT_TM