summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2015-02-25 22:04:09 +0000
committerChris Wilson <chris+github@qwirx.com>2015-02-25 22:04:09 +0000
commit9c9fbcc0b0408b8cb91cda2d1b14310aa0d80e62 (patch)
treeff9b8d36eb779eb65a868a3f3a487fda1adf2a52
parentaade9fba3086f37fa382a6f2e0f25cd6b0776e88 (diff)
Fix compile with clang on platforms other than FreeBSD.
-rw-r--r--qdbm/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/qdbm/configure.in b/qdbm/configure.in
index ee8da2e1..90cc6ebf 100644
--- a/qdbm/configure.in
+++ b/qdbm/configure.in
@@ -179,7 +179,7 @@ then
MYOPTS="-minline-all-stringops"
fi
-if uname | egrep -iq 'FreeBSD' && cc -v 2>&1 | egrep -iq ' clang '; then
+if $CC -v 2>&1 | egrep -iq ' clang '; then
MYOPTS="-O1 -fno-omit-frame-pointer"
elif uname | egrep -iq 'SunOS' || \
uname | egrep -iq 'BSD' || \