summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2009-03-28 14:04:47 +0000
committerChris Wilson <chris+github@qwirx.com>2009-03-28 14:04:47 +0000
commitb2abfe947ca6488feafae104d2aef280a900c951 (patch)
treefc7efc0f2c619587e85deaea52a084baef441eda
parent23dedbb0a4b0c036eee78edeb6f63318d14fe511 (diff)
Preserve timestamps when doing a binary copy to make a distribution, so
that the built gzipped man pages are still newer than the XML source. Make NO-LICENSE also copy the file, to avoid redundancy in manifests. Fix location of API docs. Create docs/docbook directory to avoid error in making distribution.
-rw-r--r--distribution/COMMON-MANIFEST.txt14
-rw-r--r--distribution/boxbackup/DISTRIBUTION-MANIFEST.txt6
-rwxr-xr-xinfrastructure/makedistribution.pl.in10
3 files changed, 17 insertions, 13 deletions
diff --git a/distribution/COMMON-MANIFEST.txt b/distribution/COMMON-MANIFEST.txt
index a6baaebf..b6f4b6d7 100644
--- a/distribution/COMMON-MANIFEST.txt
+++ b/distribution/COMMON-MANIFEST.txt
@@ -12,10 +12,10 @@ test/basicserver/testfiles
test/crypto
test/compress
test/win32
-docs/api-docs/common docs/api-notes
-docs/api-docs/common/lib_common docs/api-notes/lib_common
-docs/api-docs/common/lib_crypto docs/api-notes/lib_crypto
-docs/api-docs/common/lib_server docs/api-notes/lib_server
+docs/api-notes
+docs/api-notes/common/lib_common
+docs/api-notes/common/lib_crypto
+docs/api-notes/common/lib_server
MKDIR infrastructure
infrastructure/buildenv-testmain-template.cpp
infrastructure/makebuildenv.pl.in
@@ -26,13 +26,11 @@ infrastructure/printversion.pl
infrastructure/BoxPlatform.pm.in
infrastructure/mingw
infrastructure/msvc
-configure.ac
NO-LICENSE config.sub
-config.sub
NO-LICENSE config.guess
-config.guess
bootstrap
+configure.ac
+configure
parcels.txt
runtest.pl.in
NO-LICENSE-IN-DIR infrastructure/m4
-configure
diff --git a/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt b/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt
index 228b29b8..2147e6e3 100644
--- a/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt
+++ b/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt
@@ -22,15 +22,14 @@ test/backupdiff
docs/Makefile
docs/tools
docs/api-notes
-docs/api-notes/lib_raidfile
+docs/api-notes/raidfile/lib_raidfile
docs/htmlguide
docs/htmlguide/adminguide
docs/htmlguide/images
docs/htmlguide/instguide
docs/htmlguide/manpages
docs/man
-# RUN cd docs; sed -i"" -e '/^ExceptionCodes/,/^$/s/\(.*\)/# &/' Makefile
-docs/docbook/Makefile
+MKDIR docs/docbook
docs/docbook/ExceptionCodes.xml
docs/docbook/adminguide.xml
docs/docbook/bb-book.xsl
@@ -51,7 +50,6 @@ docs/docbook/raidfile-config.xml
docs/docbook/raidfile.conf.xml
docs/docbook/html
docs/docbook/html/images
-# RUN svn revert docs/Makefile
TODO.txt
BUGS.txt
contrib
diff --git a/infrastructure/makedistribution.pl.in b/infrastructure/makedistribution.pl.in
index 58c71fd5..3914780a 100755
--- a/infrastructure/makedistribution.pl.in
+++ b/infrastructure/makedistribution.pl.in
@@ -115,6 +115,13 @@ sub copy_from_list
elsif($src eq 'NO-LICENSE')
{
$no_license{$dst} = 1;
+
+ # actually copy it, to remove redundancy in manifests
+ $src = $dst;
+ $dst = $other;
+ $dst = $src if $dst eq '';
+
+ copy_file($src,$dst);
}
elsif($src eq 'RUN')
{
@@ -252,7 +259,8 @@ sub copy_file
{
# copy as binary
# print "binary copy $fn to $base_name/$dst_fn\n";
- system 'cp',$fn,"$base_name/$dst_fn"
+ my $cmd = "cp -p $fn $base_name/$dst_fn";
+ system($cmd) == 0 or die "copy failed: $cmd";
}
# copy executable bit from src