summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames O'Gorman <james@netinertia.co.uk>2008-10-27 21:17:03 +0000
committerJames O'Gorman <james@netinertia.co.uk>2008-10-27 21:17:03 +0000
commite2750aba48a6e6e7138e89e4faedb7373a0ad9fa (patch)
treeba94cd82864abbdfb25c452900eeb4fe55545972
parentfd02f8f69632fe4aab11b076fb9296571dcfdf1c (diff)
Update distribution generator.
-rw-r--r--distribution/COMMON-MANIFEST.txt11
-rw-r--r--distribution/boxbackup/CONTACT.txt6
-rw-r--r--distribution/boxbackup/DISTRIBUTION-MANIFEST.txt18
-rw-r--r--distribution/boxbackup/VERSION.txt2
-rw-r--r--docs/Makefile6
-rwxr-xr-xinfrastructure/makedistribution.pl.in6
6 files changed, 31 insertions, 18 deletions
diff --git a/distribution/COMMON-MANIFEST.txt b/distribution/COMMON-MANIFEST.txt
index f2be35ba..a6baaebf 100644
--- a/distribution/COMMON-MANIFEST.txt
+++ b/distribution/COMMON-MANIFEST.txt
@@ -1,4 +1,5 @@
RUN ./bootstrap
+RUN cd docs; make
lib/common
lib/crypto
lib/server
@@ -11,15 +12,17 @@ test/basicserver/testfiles
test/crypto
test/compress
test/win32
-docs/common notes
-docs/common/lib_common notes/lib_common
-docs/common/lib_crypto notes/lib_crypto
-docs/common/lib_server notes/lib_server
+docs/api-docs/common docs/api-notes
+docs/api-docs/common/lib_common docs/api-notes/lib_common
+docs/api-docs/common/lib_crypto docs/api-notes/lib_crypto
+docs/api-docs/common/lib_server docs/api-notes/lib_server
MKDIR infrastructure
infrastructure/buildenv-testmain-template.cpp
infrastructure/makebuildenv.pl.in
infrastructure/makedistribution.pl.in
infrastructure/makeparcels.pl.in
+infrastructure/parcelpath.pl
+infrastructure/printversion.pl
infrastructure/BoxPlatform.pm.in
infrastructure/mingw
infrastructure/msvc
diff --git a/distribution/boxbackup/CONTACT.txt b/distribution/boxbackup/CONTACT.txt
index 849c1e76..9f12e435 100644
--- a/distribution/boxbackup/CONTACT.txt
+++ b/distribution/boxbackup/CONTACT.txt
@@ -1,6 +1,6 @@
-http://www.fluffy.co.uk/boxbackup/
+http://www.boxbackup.org/
-Ben Summers
-ben@fluffy.co.uk
+Ben Summers & contributors
+boxbackup@boxbackup.org
diff --git a/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt b/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt
index 0f38279f..34653c8e 100644
--- a/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt
+++ b/distribution/boxbackup/DISTRIBUTION-MANIFEST.txt
@@ -19,12 +19,15 @@ test/backupstorepatch
test/bbackupd
test/bbackupd/testfiles
test/backupdiff
-docs/raidfile notes
-docs/raidfile/lib_raidfile notes/lib_raidfile
-docs/backup notes
-documentation
-documentation/html
-documentation/html/images
+docs/api-docs/raidfile docs/api-notes
+docs/api-docs/raidfile/lib_raidfile docs/api-notes/lib_raidfile
+docs/api-docs/backup docs/api-notes
+docs/box-html docs/htmlguide
+docs/box-html/adminguide docs/htmlguide/adminguide
+docs/box-html/images docs/htmlguide/images
+docs/box-html/instguide docs/htmlguide/instguide
+docs/box-html/man-html docs/htmlguide/manpages
+docs/man
TODO.txt
BUGS.txt
contrib
@@ -35,6 +38,9 @@ REPLACE-VERSION-IN contrib/rpm/boxbackup.spec
NO-LICENSE-IN-DIR contrib/solaris
NO-LICENSE-IN-DIR contrib/suse
NO-LICENSE-IN-DIR contrib/bbreporter
+NO-LICENSE-IN-DIR contrib/windows
+NO-LICENSE-IN-DIR contrib/windows/installer
+NO-LICENSE-IN-DIR contrib/windows/installer/tools
infrastructure/msvc
NO-LICENSE-IN-DIR infrastructure/msvc/2003
NO-LICENSE-IN-DIR infrastructure/msvc/2005
diff --git a/distribution/boxbackup/VERSION.txt b/distribution/boxbackup/VERSION.txt
index d46ff63a..990d8ebe 100644
--- a/distribution/boxbackup/VERSION.txt
+++ b/distribution/boxbackup/VERSION.txt
@@ -1,2 +1,2 @@
-0.10_plus_USE_SVN_VERSION
+0.11_USE_SVN_VERSION
boxbackup
diff --git a/docs/Makefile b/docs/Makefile
index 83f8d152..0a5d6145 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -21,9 +21,9 @@ DOCBOOK=http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
all: docs
docs: instguide adminguide manpages
- mkdir -p $(HTMLPREFIX)/images
- cp html/images/*.png $(HTMLPREFIX)/images/.
- cp html/*.css $(HTMLPREFIX)/.
+ @mkdir -p $(HTMLPREFIX)/images
+ @cp html/images/*.png $(HTMLPREFIX)/images/.
+ @cp html/*.css $(HTMLPREFIX)/.
adminguide: $(HTMLPREFIX)/adminguide/index.html
diff --git a/infrastructure/makedistribution.pl.in b/infrastructure/makedistribution.pl.in
index 2ef8b960..32566eb2 100755
--- a/infrastructure/makedistribution.pl.in
+++ b/infrastructure/makedistribution.pl.in
@@ -332,7 +332,11 @@ sub copy_dir
next if m/\AMakefile\Z/;
next if m/\Aautogen/;
next if m/-smf-method\Z/; # copy only the .in versions
- next if m/-manifest.xml\Z/; # copy onlt the .in versions
+ next if m/-manifest.xml\Z/; # copy only the .in versions
+ if($dir eq 'docs') {
+ next if m/.(x[sm]l|tmpl)\Z/; # don't include doc sources
+ next if m/generate_except_xml.pl/;
+ }
next if !-f "$dir/$_";
copy_file("$dir/$_","$dst_dir/$_");