summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-02-25 00:48:07 +0000
committerChris Wilson <chris+github@qwirx.com>2008-02-25 00:48:07 +0000
commitf583e6af4d555be860ab6799907605529169ac71 (patch)
tree975ea97d163613d66d6a15a25b599ece0d81bf00
parent1a948d1c2b1eb2d8b868e81648fb19d359b71a8e (diff)
Don't try to define our own dirfd() macro on platforms where interception
is impossible (such as win32) because it's not needed and fails on win32.
-rw-r--r--lib/common/BoxPlatform.h8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/common/BoxPlatform.h b/lib/common/BoxPlatform.h
index 2f0096aa..acec9cb3 100644
--- a/lib/common/BoxPlatform.h
+++ b/lib/common/BoxPlatform.h
@@ -165,11 +165,11 @@
#include "emu.h"
#endif
-// Solaris has no dirfd(x) macro or function, and we need one.
-// We cannot define macros with arguments directly using AC_DEFINE,
-// so do it here instead of in configure.ac.
+// Solaris has no dirfd(x) macro or function, and we need one for
+// intercept tests. We cannot define macros with arguments directly
+// using AC_DEFINE, so do it here instead of in configure.ac.
-#if ! HAVE_DECL_DIRFD
+#if ! defined PLATFORM_CLIB_FNS_INTERCEPTION_IMPOSSIBLE && ! HAVE_DECL_DIRFD
#ifdef HAVE_DIR_D_FD
#define dirfd(x) (x)->d_fd
#elif defined HAVE_DIR_DD_FD