summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2007-01-13 15:41:12 +0000
committerChris Wilson <chris+github@qwirx.com>2007-01-13 15:41:12 +0000
commitf66dda5e642ed73671d2a1ede0237646f52a731d (patch)
tree82ee4e6451de6a0b11b14982f8547cab1013e776
parentbd6c2f418ce4e1d369c46840ccf89bf8b03e83bb (diff)
Rename makedistribution.pl to makedistribution.pl.in.
Auto-generate makedistribution.pl in configure, to replace @PERL@ in shebang line. Process spec files as text files, to allow removing private parts. (refs #3)
-rw-r--r--configure.ac1
-rwxr-xr-xinfrastructure/makedistribution.pl.in (renamed from infrastructure/makedistribution.pl)2
2 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8b0cf7d0..2eaa232e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -240,6 +240,7 @@ AX_CONFIG_SCRIPTS([bin/bbackupd/bbackupd-config
bin/bbstored/bbstored-config
infrastructure/makebuildenv.pl
infrastructure/makeparcels.pl
+ infrastructure/makedistribution.pl
lib/common/makeexception.pl
lib/raidfile/raidfile-config
lib/server/makeprotocol.pl
diff --git a/infrastructure/makedistribution.pl b/infrastructure/makedistribution.pl.in
index 16f7409b..52e1c2e4 100755
--- a/infrastructure/makedistribution.pl
+++ b/infrastructure/makedistribution.pl.in
@@ -6,7 +6,7 @@ use Symbol;
my %comment_chars = ('cpp' => '// ', 'h' => '// ', 'pl' => '# ', 'pm' => '# ', '' => '# ');
# other extensions which need text copying, just to remove the private stuff
-my %text_files = ('txt' => 1);
+my %text_files = ('txt' => 1, 'spec' => 1);
# files which don't get the license added
my %no_license = (); # 'filename' => 1