summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2017-06-17 19:23:49 -0400
committerReinhard Tartler <siretart@tauware.de>2017-06-17 19:24:16 -0400
commitfd859cc013562737043591e725c224a1cdc2187c (patch)
tree5ab9642bb57284bd1974d143cb667fca4a06f66e
parentbc4cd6afe82a5d9e18a1df5e72d34154c260dafc (diff)
Fix upstream version identification
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 525f257d..2acc53ac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,8 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+include /usr/share/dpkg/pkg-info.mk
+
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -21,7 +23,7 @@ configure: configure-stamp
configure-stamp:
dh_testdir
dh_autotools-dev_updateconfig
- echo "0.11rc8+`cat .svnrevision`" > VERSION.txt
+ echo "$(DEB_VERSION_UPSTREAM_REVISION)" > VERSION.txt
echo "boxbackup" >> VERSION.txt
sh -x ./bootstrap
./configure $(DEB_EXTRA_CONFIG_FLAGS) LDFLAGS="-Wl,--as-needed"