summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2018-02-24 14:35:48 +0000
committerChris Wilson <chris+github@qwirx.com>2018-03-08 22:20:03 +0000
commit9f53912f0967a4077c8c41f80d6d52b15b007a4c (patch)
treeec232ae0943def98e8c44a89750a3bddaa381aa4
parentc08932c6e5e1609835219e9f42efe46bb6624a7d (diff)
Fix error in t-gdb when no debugger is detected
-rw-r--r--configure.ac1
-rwxr-xr-xinfrastructure/makebuildenv.pl.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f9f481d5..58a04406 100644
--- a/configure.ac
+++ b/configure.ac
@@ -139,6 +139,7 @@ Large files: $box_cv_have_large_file_support
Berkeley DB: $ax_path_bdb_ok
Readline: $have_libreadline
Extended attributes: $ac_cv_header_sys_xattr_h
+Debugger: ${with_debugger:-neither GDB nor LLDB detected!}
EOC
cat > config.env <<EOC
diff --git a/infrastructure/makebuildenv.pl.in b/infrastructure/makebuildenv.pl.in
index d5ac9f2f..48958ba1 100755
--- a/infrastructure/makebuildenv.pl.in
+++ b/infrastructure/makebuildenv.pl.in
@@ -628,7 +628,7 @@ __E
{
writetestfile("$mod/t-gdb",
"echo 'No debugger was detected by configure script'\n".
- "exit 2");
+ "exit 2", $mod);
}
}