summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2006-10-16 19:23:47 +0000
committerChris Wilson <chris+github@qwirx.com>2006-10-16 19:23:47 +0000
commit4cf0546485a28ba331edc75dd0d263a6e2259462 (patch)
tree6660c6bdd0a88510c7e47b0a7ef19296dc5eb555
parent7b0b44a30ce55a12c082f80b8f9c1465e8d3717a (diff)
Don't check for nanosleep, random device, or flock/F_SETLK on any mingw32
platform (including mingw32msvc). (refs #3)
-rw-r--r--configure.ac27
1 files changed, 21 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index b5b7a4cc..c6b27fea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,10 +36,15 @@ fi
### Checks for libraries.
-if test "$target_os" != "mingw32" -a "$target_os" != "winnt"; then
+case $target_os in
+mingw32*) ;;
+winnt) ;;
+*)
AC_SEARCH_LIBS([nanosleep], [rt], [ac_have_nanosleep=yes],
[AC_MSG_ERROR([[cannot find a short sleep function (nanosleep)]])])
-fi
+ ;;
+esac
+
AC_CHECK_LIB([z], [zlibVersion],, [AC_MSG_ERROR([[cannot find zlib]])])
VL_LIB_READLINE([have_libreadline=yes], [have_libreadline=no])
@@ -126,12 +131,16 @@ if test "x$ac_cv_c_bigendian" != "xyes"; then
AX_BSWAP64
fi
-if test "$target_os" != "mingw32"; then
+case $target_os in
+mingw32*) ;;
+winnt*) ;;
+*)
AX_RANDOM_DEVICE
AX_CHECK_MOUNT_POINT(,[
AC_MSG_ERROR([[cannot work out how to discover mount points on your platform]])
])
-fi
+;;
+esac
AX_CHECK_MALLOC_WORKAROUND
@@ -170,13 +179,19 @@ AC_CACHE_CHECK([if we have large file support enabled], [have_large_file_support
AC_CHECK_FUNCS([flock])
AC_CHECK_DECLS([O_EXLOCK],,, [[#include <fcntl.h>]])
AC_CHECK_DECLS([F_SETLK],,, [[#include <fcntl.h>]])
+
+case $target_os in
+mingw32*) ;;
+winnt*) ;;
+*)
if test "x$ac_cv_func_flock" != "xyes" && \
test "x$ac_cv_have_decl_O_EXLOCK" != "xyes" && \
- test "x$ac_cv_have_decl_F_SETLK" != "xyes" && \
- test "$target_os" != "mingw32" -a "$target_os" != "winnt"
+ test "x$ac_cv_have_decl_F_SETLK" != "xyes"
then
AC_MSG_ERROR([[cannot work out how to do file locking on your platform]])
fi
+;;
+esac
## Get tmpdir
temp_directory_name="/tmp"