summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-10-05 15:23:16 +0000
committerChris Wilson <chris+github@qwirx.com>2008-10-05 15:23:16 +0000
commit5958d03cf327b327c63e482dfd2a110fb70a2a3c (patch)
treeab69ace2bd826794bf2cc0893b2fbb5862662b8f
parentbb591d01f13a5c50d6cee571097f1119150bba6d (diff)
Substitute parcel directory and Box version into InstallJammer config
file for Windows installer.
-rw-r--r--configure.ac12
-rwxr-xr-xcontrib/windows/installer/boxbackup.mpi.in (renamed from contrib/windows/installer/boxbackup.mpi)4
2 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8edc1373..3c2da5ff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -306,6 +306,17 @@ AC_SUBST([sbindir_expanded])
AC_SUBST([sysconfdir_expanded])
AC_SUBST([localstatedir_expanded])
+## Figure out the client parcel directory and substitute it
+client_parcel_dir=`perl infrastructure/parcelpath.pl client $target_os`
+os_name=`uname -o`
+if test "$os_name" = "Cygwin"; then
+ client_parcel_dir=`cygpath -wa $client_parcel_dir`
+fi
+AC_SUBST([client_parcel_dir])
+
+## Figure out version and substitute it in
+box_version=`perl infrastructure/printversion.pl`
+AC_SUBST([box_version])
### Output files
AC_CONFIG_FILES([infrastructure/BoxPlatform.pm])
@@ -323,6 +334,7 @@ AX_CONFIG_SCRIPTS([bin/bbackupd/bbackupd-config
contrib/solaris/bbstored-manifest.xml
contrib/solaris/bbackupd-smf-method
contrib/solaris/bbstored-smf-method
+ contrib/windows/installer/boxbackup.mpi
infrastructure/makebuildenv.pl
infrastructure/makeparcels.pl
infrastructure/makedistribution.pl
diff --git a/contrib/windows/installer/boxbackup.mpi b/contrib/windows/installer/boxbackup.mpi.in
index 1993deab..305ad86b 100755
--- a/contrib/windows/installer/boxbackup.mpi
+++ b/contrib/windows/installer/boxbackup.mpi.in
@@ -21,7 +21,7 @@ AutoRefreshFiles
Yes
BBVersionNo
-1857
+@box_version@
BrandName
GigaLock
@@ -273,7 +273,7 @@ test
}
FileGroup ::481451CC-F49C-D389-8645076F595B -setup Install -active Yes -platforms {Windows MacOS-X} -name {Program Files} -parent FileGroups
-File ::B9F58CFC-EE7A-BEE4-62CB-2C10665095A2 -filemethod {Update files with more recent dates} -type dir -directory <%InstallDir%> -name /home/petjal/doc/teb/cli/bu/installer/win/2.2 -location C:/cygwin/home/Chris/general/parcels/boxbackup-chris_general_1988M-backup-client-mingw32 -parent 481451CC-F49C-D389-8645076F595B
+File ::B9F58CFC-EE7A-BEE4-62CB-2C10665095A2 -filemethod {Update files with more recent dates} -type dir -directory <%InstallDir%> -name /home/petjal/doc/teb/cli/bu/installer/win/2.2 -location @client_parcel_dir@ -parent 481451CC-F49C-D389-8645076F595B
File ::CDDED10B-2747-DD07-5F9D-42A7FD7BB7E6 -name LICENSE.txt -parent B9F58CFC-EE7A-BEE4-62CB-2C10665095A2
File ::D6E262BC-8A84-B6DB-794B-8FDC8AECB079 -name mgwz.dll -parent B9F58CFC-EE7A-BEE4-62CB-2C10665095A2
File ::E56A0360-7D7F-D99E-E9A4-3C20BC4C2B99 -name mingwm10.dll -parent B9F58CFC-EE7A-BEE4-62CB-2C10665095A2