summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2018-01-01 11:12:16 +0000
committerChris Wilson <chris+github@qwirx.com>2018-01-01 16:13:16 +0000
commit971fbbce13186199b3ac67f35a7fb5acfc777295 (patch)
treef62b18ee15180651bb0954620c7acf4ba1bd9c96
parenta0fa0c4f5f338335034f172af290025d48d5a1d5 (diff)
Speed up superbuild rebuild by not extracting Boost again
(cherry picked from commit 8976906a563ab04eb3d1310c59d4c13cdc3b525e)
-rw-r--r--infrastructure/cmake/windows/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/infrastructure/cmake/windows/CMakeLists.txt b/infrastructure/cmake/windows/CMakeLists.txt
index 80d1369b..d78faecc 100644
--- a/infrastructure/cmake/windows/CMakeLists.txt
+++ b/infrastructure/cmake/windows/CMakeLists.txt
@@ -100,6 +100,8 @@ ExternalProject_Add(boost
URL "http://downloads.sourceforge.net/project/boost/boost/${BOOST_VERSION}/boost_${BOOST_VERSION_UNDERSCORES}.tar.bz2"
URL_HASH ${BOOST_HASH}
# DOWNLOAD_NO_PROGRESS 1
+ # Disable automatic updating (untarring) as it's slow and not necessary
+ UPDATE_DISCONNECTED 1
CONFIGURE_COMMAND ${CMAKE_COMMAND} -E echo "No configure step needed"
BUILD_COMMAND ${CMAKE_COMMAND} -E echo "No build step needed"
INSTALL_COMMAND ${CMAKE_COMMAND} -E echo "No install step needed"