summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-01-23 20:01:40 +0000
committerChris Wilson <chris+github@qwirx.com>2008-01-23 20:01:40 +0000
commitb70df10f8b5b9e4d7efb4f0c9afcaaccf6138b76 (patch)
treef874e5d2f15b59f9b86a5b13bdc32974dc7b0b76
parentc10a73a1812e4885f3b84992277606dee85710cb (diff)
Report the $build_os when making build environment, useful for debugging
platforms like GNU/kFreeBSD where we don't yet detect the proper type of make to run.
-rwxr-xr-xinfrastructure/makebuildenv.pl.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/infrastructure/makebuildenv.pl.in b/infrastructure/makebuildenv.pl.in
index 9fe0a798..51ae80dc 100755
--- a/infrastructure/makebuildenv.pl.in
+++ b/infrastructure/makebuildenv.pl.in
@@ -12,7 +12,7 @@ $|=1;
# note: Mac OS X resource forks and .DS_Store files are explicity ignored
-print "Box build environment setup.\n\n";
+print "Box build environment setup for '$build_os'.\n\n";
my @implicit_deps = ('lib/common');
@@ -741,7 +741,7 @@ __E
additional_objects_from_make_fragment("$mod/Makefile.extra", \@objs, \@makefile_includes);
additional_objects_from_make_fragment("$mod/Makefile.extra.$build_os", \@objs, \@makefile_includes);
- my $o_file_list = join(' ',map {'$(OUTDIR)/'.$_.'.o'} @objs);
+ my $o_file_list = join(' ',map {'$(OUTDIR)/'.$_.'.o'} sort @objs);
if ($has_deps and not $bsd_make)
{