summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-10-08 19:59:20 +0000
committerChris Wilson <chris+github@qwirx.com>2008-10-08 19:59:20 +0000
commite58e758f39aa4aca63b8ca3939804fcae64ff126 (patch)
tree5bd9e748b91b1b7202a5e62b93c67cfb3bc68114
parent9884089c0cf07bfeb7902cfba19f60d692d581bc (diff)
Add @build_dir@ as a substituted variable in autoconf script.
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index aabb2074..d83c601c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -307,12 +307,18 @@ AC_SUBST([sysconfdir_expanded])
AC_SUBST([localstatedir_expanded])
## Figure out the client parcel directory and substitute it
-client_parcel_dir=`perl infrastructure/parcelpath.pl client $target_os`
+build_dir=`dirname $0`
+build_dir=`cd $build_dir && pwd`
+client_parcel_dir=`perl infrastructure/parcelpath.pl backup-client $target_os`
+
os_name=`uname -o`
if test "$os_name" = "Cygwin"; then
client_parcel_dir=`cygpath -wa $client_parcel_dir | sed -e 's|\\\|/|g'`
+ build_dir=`cygpath -wa $build_dir | sed -e 's|\\\|/|g'`
fi
+
AC_SUBST([client_parcel_dir])
+AC_SUBST([build_dir])
## Figure out version and substitute it in
box_version=`perl infrastructure/printversion.pl`