summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2005-12-12 20:50:00 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2005-12-12 20:50:00 +0000
commit3bedf8846f4d7a5cb38276b274662d62a36dcd52 (patch)
tree9d51de8b0f3d06ba6549a5a1958e52f592343140 /configure.ac
parent81d8eda2419e7a23088a98cdfc52a305c9ceac0d (diff)
Marged chris/win32/merge/07-win32-fixes at r210 to trunk
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 14 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 2915a580..ef903ad8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,10 @@ AC_INIT([Box Backup], 0.09, [box@fluffy.co.uk])
AC_CONFIG_SRCDIR([lib/common/Box.h])
AC_CONFIG_HEADERS([lib/common/config.h])
+touch install-sh
+AC_CANONICAL_SYSTEM
+# echo "Build target OS: '$target_os'"
+test -s install-sh || rm install-sh
### Checks for programs.
@@ -26,9 +30,11 @@ fi
### Checks for libraries.
+if test "$target_os" != "mingw32" -a "$target_os" != "winnt"; then
+AC_SEARCH_LIBS([nanosleep], [rt], [ac_have_nanosleep=yes],
+ [AC_MSG_ERROR([[Cannot find a short sleep function (nanosleep)]])])
+fi
-AC_SEARCH_LIBS([nanosleep], [rt],,
- [AC_MSG_ERROR([[Cannot find library with nanosleep]])])
AC_CHECK_LIB([z], [zlibVersion],, [AC_MSG_ERROR([[Cannot find zlib]])])
AX_CHECK_BDB_V1
VL_LIB_READLINE
@@ -89,8 +95,12 @@ AX_CHECK_DIRENT_D_TYPE
AC_SYS_LARGEFILE
AX_CHECK_LLONG_MINMAX
AX_CHECK_DEFINE_PRAGMA
+
+if test "$target_os" != "mingw32"; then
AX_RANDOM_DEVICE
-AX_CHECK_MOUNT_POINT(, [AC_MSG_ERROR([[cannot work out how to discover mount points on your platform]])])
+fi
+
+AX_CHECK_MOUNT_POINT([],[])
AX_CHECK_MALLOC_WORKAROUND
@@ -124,12 +134,6 @@ fi
AC_CHECK_FUNCS([flock])
AC_CHECK_DECLS([O_EXLOCK],,, [[#include <fcntl.h>]])
AC_CHECK_DECLS([F_SETLK],,, [[#include <fcntl.h>]])
-if test "x$ac_cv_func_flock" != "xyes" && \
- test "x$ac_cv_have_decl_O_EXLOCK" != "xyes" && \
- test "x$ac_cv_have_decl_F_SETLK" != "xyes"
-then
- AC_MSG_ERROR([[cannot work out how to do file locking on your platform]])
-fi
## Get tmpdir
temp_directory_name="/tmp"
@@ -144,7 +148,7 @@ AC_ARG_ENABLE(
[static-bin],
[AC_HELP_STRING([--enable-static-bin], [Link binaries with static libraries])])
if test "x$enable_static_bin" = "xyes"; then
- AC_CHECK_LIB([ssl],[SSL_read])
+ AC_CHECK_LIB([ssl],[SSL_read],[],[],[crypto])
LIBS="-Wl,-Bstatic $LIBS -Wl,-Bdynamic"
fi