summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-01-20 16:46:06 +0000
committerChris Wilson <chris+github@qwirx.com>2008-01-20 16:46:06 +0000
commit143d57d8e7f974f4d3530c10ba19ee8bf6816874 (patch)
treec62655a5962db28375afec8a1453ffb4cb97bbd1 /configure.ac
parent8a7f1a2a7ccb1a739d90f2de3fa333d24bcc73bb (diff)
Add -Wundef to CXXFLAGS, only if using gcc (sun cc doesn't like it)
Substitute in the contributed Solaris SMF files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3aa96832..e780e0b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,7 +22,7 @@ if test "x$ac_cv_cxx_exceptions" != "xyes" || \
fi
if test "x$GXX" = "xyes"; then
# Use -Wall if we have gcc. This gives better warnings
- AC_SUBST([CXXFLAGS_STRICT], ['-Wall'])
+ AC_SUBST([CXXFLAGS_STRICT], ['-Wall -Wundef'])
# Use -rdynamic if we have gcc. This is needed for backtrace
AC_SUBST([LDADD_RDYNAMIC], ['-rdynamic'])
fi
@@ -284,6 +284,10 @@ AX_CONFIG_SCRIPTS([bin/bbackupd/bbackupd-config
bin/bbackupquery/makedocumentation.pl
bin/bbstored/bbstored-certs
bin/bbstored/bbstored-config
+ contrib/solaris/bbackupd-manifest.xml
+ contrib/solaris/bbstored-manifest.xml
+ contrib/solaris/bbackupd-smf-method
+ contrib/solaris/bbstored-smf-method
infrastructure/makebuildenv.pl
infrastructure/makeparcels.pl
infrastructure/makedistribution.pl