summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2006-10-16 19:26:51 +0000
committerChris Wilson <chris+github@qwirx.com>2006-10-16 19:26:51 +0000
commitbd610e6fea1585387be0127215379c0b5d92c388 (patch)
tree40ab12540fddfb772cdde24457a56986dc7831d5 /configure.ac
parent6b67a185db7d655e0ce74f47b6d51458ab4dc43b (diff)
Different check for have_regex_h (the old one doesn't seem to work on MinGW).
(refs #3)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5ce21491..564a9076 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,13 +94,16 @@ esac
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
-AC_CHECK_HEADERS([execinfo.h process.h pwd.h regex.h signal.h])
+AC_CHECK_HEADERS([execinfo.h process.h pwd.h signal.h])
AC_CHECK_HEADERS([syslog.h time.h])
AC_CHECK_HEADERS([netinet/in.h])
AC_CHECK_HEADERS([sys/param.h sys/socket.h sys/time.h sys/types.h sys/wait.h])
AC_CHECK_HEADERS([sys/uio.h sys/xattr.h])
-if test "$ac_cv_header_regex_h" = "yes"; then
+AC_CHECK_HEADER([regex.h], [have_regex_h=yes])
+
+if test "$have_regex_h" = "yes"; then
+ AC_DEFINE([HAVE_REGEX_H], [1], [Define to 1 if regex.h is available])
AC_SEARCH_LIBS([regcomp], ["pcreposix -lpcre"])
fi
@@ -258,7 +261,7 @@ A summary of the build configuration is below. Box Backup will function
without these features, but will work better where they are present. Refer
to the documentation for more information on each feature.
-Regular expressions: $ac_cv_header_regex_h
+Regular expressions: $have_regex_h
Large files: $have_large_file_support
Berkeley DB: $ax_path_bdb_ok
Readline: $have_libreadline