summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2006-11-23 19:54:51 +0000
committerChris Wilson <chris+github@qwirx.com>2006-11-23 19:54:51 +0000
commit366574d921bf39a356d558ef8d61d78181a7af9b (patch)
treec71d9042856a032e8627e87158d58664684999da /configure.ac
parentca0c40ce216de416cd8ada05ab369c2971ee4a71 (diff)
Use gettimeofday() to increase accuracy of GetCurrentBoxTime() on
platforms which support it. Fixes busy waits for 1 second in backup client when time for next backup is not on a 1 second boundary (which it never is). (refs #3)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8b6221a2..99165a38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,7 +158,7 @@ AC_FUNC_CLOSEDIR_VOID
AC_FUNC_ERROR_AT_LINE
AC_TYPE_SIGNAL
AC_FUNC_STAT
-AC_CHECK_FUNCS([getpeereid lchown setproctitle getpid])
+AC_CHECK_FUNCS([getpeereid lchown setproctitle getpid gettimeofday])
# NetBSD implements kqueue too differently for us to get it fixed by 0.10
# TODO: Remove this when NetBSD kqueue implementation is working
netbsd_hack=`echo $target_os | sed 's/netbsd.*/netbsd/'`