summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2006-02-11 02:28:52 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2006-02-11 02:28:52 +0000
commit61494e43ae5a9b505b7e9e2b62f30e6462e450e8 (patch)
tree667174688c351066446a38665251df29178a5915 /configure.ac
parentd6dc2eac174530497786a7e4604db051f44a1d46 (diff)
Workaround for autoconf's unexpanded directory substitutions vs. the current Makefile not being able to expand them itself.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f2c7ea5..4239b821 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,6 +175,18 @@ if test "x$enable_static_bin" = "xyes"; then
LIBS="-Wl,-Bstatic $LIBS -Wl,-Bdynamic"
fi
+## Kludge to allow makeparcels.pl to use bindir. This is not a good long term
+## solution because it prevents use of "make exec_prefix=/some/dir"
+saved_prefix=$prefix
+saved_exec_prefix=$exec_prefix
+test "x$prefix" = xNONE && prefix=$ac_default_prefix
+test "x$exec_prefix" = xNONE && exec_prefix='${prefix}'
+bindir_expanded=`eval "echo $bindir"`
+bindir_expanded=`eval "echo $bindir_expanded"`
+prefix=$saved_prefix
+exec_prefix=$saved_exec_prefix
+AC_SUBST([bindir_expanded])
+
### Output files
AC_CONFIG_FILES([infrastructure/BoxPlatform.pm])