summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2006-02-12 03:16:57 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2006-02-12 03:16:57 +0000
commit9ff0d883fcc564ad91221953049a47e0937063fa (patch)
tree1294b812684844684ee476d4a1023be4e2d7a579 /configure.ac
parentdc24ad5027955df1e3555beacf00b77e382e6d2e (diff)
This ppc problem is clearly a common big-endian platform issue.
Remove ppc hack and configure option. Replace dubious casts with clearer use of memcpy to make this work on all platforms all of the time. Note that there isn't really a call to memcpy, the compiler inlines it as 2 int copies which is an insignificant overhead (even true with -O0).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 2c375a6f..4239b821 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,17 +10,6 @@ touch install-sh
AC_CANONICAL_SYSTEM
test -s install-sh || rm install-sh
-
-### Temporary hacks
-AC_ARG_ENABLE(
- [ppc-workaround],
- [AC_HELP_STRING([--enable-ppc-workaround],
- [Enable a workaround for a compiler bug in GCC on PPC platforms (raidfile tests fail).])])
-if test "x$enable_ppc_workaround" = "xyes"; then
- AC_DEFINE([HAVE_PPC_WORKAROUND], 1, [Define to 1 to workaround a GCC compiler bug on PPC])
-fi
-
-
### Checks for programs.
AC_LANG([C++])