summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2006-01-04 00:31:49 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2006-01-04 00:31:49 +0000
commitbf4817a8f69bc96a62e2c916011c2f4fab89fee8 (patch)
tree5f2594c7d9af0fff2bdaa9f5080f71abe59fb05f /configure.ac
parent2f1076aa7e8c531ec7e4405965753d204aa7a242 (diff)
Rewrite configure check for readline lib to match libraries to headers and be more selective.
Also changes --enable-gnu-readline which intentionally used to prefer editline over readline even when specified (for licence goodness), to now prefer readline if requested. This is probably less confusing to a user.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 1aafb39d..6f334be7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,9 +35,7 @@ if test "$target_os" != "mingw32" -a "$target_os" != "winnt"; then
[AC_MSG_ERROR([[cannot find a short sleep function (nanosleep)]])])
fi
AC_CHECK_LIB([z], [zlibVersion],, [AC_MSG_ERROR([[cannot find zlib]])])
-VL_LIB_READLINE
-have_libreadline=no
-test "x$vl_cv_lib_readline" != "xno" && have_libreadline=yes
+VL_LIB_READLINE([have_libreadline=yes], [have_libreadline=no])
## Check for Berkely DB. Restrict to certain versions
AX_PATH_BDB(, [
@@ -212,7 +210,7 @@ case "$vl_cv_lib_readline" in
*readline*)
echo
AC_MSG_WARN([[do not distribute binaries compiled against GNU readline,
-as this would violate the GNU readline licence, which is GPL. You may use
+as this could violate the GNU readline licence, which is GPL. You may use
libedit or libeditline instead.]])
;;
esac