summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-01-31 23:43:24 +0000
committerChris Wilson <chris+github@qwirx.com>2008-01-31 23:43:24 +0000
commit2ccdaf9a575f4cc0d758a87300b7cf51d96c9779 (patch)
tree7ab5878ef3b04c9566bd26ee2319cad2c4ae57a5 /configure.ac
parent71fc8d094e57a344d98984cf71f0a38c59ff9314 (diff)
Add support for nanosecond timestamps in struct stat on Linux.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 85b8c968..07f7f3c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,6 +159,8 @@ AC_TYPE_SIZE_T
AC_CHECK_MEMBERS([struct stat.st_flags])
AC_CHECK_MEMBERS([struct stat.st_mtimespec])
+AC_CHECK_MEMBERS([struct stat.st_atim.tv_nsec])
+AC_CHECK_MEMBERS([struct stat.st_atimensec])
AC_CHECK_MEMBERS([struct sockaddr_in.sin_len],,, [[
#include <sys/types.h>
#include <netinet/in.h>