summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-04-04 21:59:29 +0000
committerChris Wilson <chris+github@qwirx.com>2008-04-04 21:59:29 +0000
commit3661f3624acc46590d5504fda4f8714255fb2c8e (patch)
treee2cd17e19718d3f46944979a23e4c93dcf92584b /configure.ac
parent2f8d0c29536cdb306b525b78638727da4ead0022 (diff)
Tailorization
Import of the upstream sources from Repository: http://localhost:8000/ Kind: hg Revision: 7807b7768163f1c2537756abe5416063989cebb1 Original author: tailor@rocio.int.aidworld.org Date: 2008-03-16 19:44:36+00:00
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f8390ec9..f68c8b9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,10 @@ AC_INIT([Box Backup], 0.11, [boxbackup@fluffy.co.uk])
AC_CONFIG_SRCDIR([lib/common/Box.h])
AC_CONFIG_HEADERS([lib/common/BoxConfig.h])
+# override default sysconfdir, for backwards compatibility
+test "$sysconfdir" = NONE && sysconfdir=/etc
+test "$localstatedir" = NONE && localstatedir=/var/run
+
touch install-sh
AC_CANONICAL_SYSTEM
test -s install-sh || rm install-sh
@@ -58,6 +62,7 @@ winnt) ;;
;;
esac
+AC_CHECK_HEADER([zlib.h],, [AC_MSG_ERROR([[cannot find zlib.h]])])
AC_CHECK_LIB([z], [zlibVersion],, [AC_MSG_ERROR([[cannot find zlib]])])
VL_LIB_READLINE([have_libreadline=yes], [have_libreadline=no])
@@ -269,10 +274,6 @@ if test "x$enable_static_bin" = "xyes"; then
LIBS="-Wl,-Bstatic $LIBS -Wl,-Bdynamic"
fi
-# override default sysconfdir, for backwards compatibility
-test "$sysconfdir" = '${prefix}/etc' && sysconfdir=/etc
-test "$localstatedir" = '${prefix}/var' && localstatedir=/var
-
## Kludge to allow makeparcels.pl to use bindir. This is not a good long term
## solution because it prevents use of "make exec_prefix=/some/dir"
saved_prefix=$prefix