summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-01-22 01:00:12 +0000
committerChris Wilson <chris+github@qwirx.com>2008-01-22 01:00:12 +0000
commitc10a73a1812e4885f3b84992277606dee85710cb (patch)
tree5bb475682005c323fce5641d865b88360f969266 /configure.ac
parentcede082dc35481d4d47d389f56d9f406999d35d0 (diff)
Detect whether struct DIR has d_fd or dd_fd member and define the
dirfd() macro accordingly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0cca65a9..8d37cea0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -159,6 +159,8 @@ AC_CHECK_MEMBERS([struct sockaddr_in.sin_len],,, [[
#include <sys/types.h>
#include <netinet/in.h>
]])
+AC_CHECK_MEMBERS([DIR.d_fd],,, [[#include <dirent.h>]])
+AC_CHECK_MEMBERS([DIR.dd_fd],,, [[#include <dirent.h>]])
AC_CHECK_DECLS([INFTIM],,, [[#include <poll.h>]])
AC_CHECK_DECLS([SO_PEERCRED],,, [[#include <sys/socket.h>]])