summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2006-03-04 01:33:46 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2006-03-04 01:33:46 +0000
commitdefac6623afe8b7d765a9477371fbc47da855c19 (patch)
treeb6d5c9e77d896a67ee1d56bc9ffa9d703ae45c81 /configure.ac
parent6f868d48446f4196d2ad69e7ca9be42047ea2d5e (diff)
This is part 1 of a patch from James O'Gorman.
configure now detects perl executable location and updates all scripts to use the correct path; also adds PERL_EXECUTABLE define to BoxConfig.h. makebuildenv.pl adds PERL define to all makefiles.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 24 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 714603b2..ef0cfeb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT([Box Backup], 0.09, [box@fluffy.co.uk])
+AC_INIT([Box Backup], 0.10, [box@fluffy.co.uk])
AC_CONFIG_SRCDIR([lib/common/Box.h])
AC_CONFIG_HEADERS([lib/common/BoxConfig.h])
@@ -26,6 +26,12 @@ if test "x$GXX" = "xyes"; then
# Use -rdynamic if we have gcc. This is needed for backtrace
AC_SUBST([LDADD_RDYNAMIC], ['-rdynamic'])
fi
+AC_PATH_PROG([PERL], [perl], [no])
+if test "x$PERL" != "xno"; then
+ AC_DEFINE_UNQUOTED([PERL_EXECUTABLE], ["$PERL"], [Location of the perl executable])
+else
+ AC_MSG_ERROR([[perl executable was not found]])
+fi
### Checks for libraries.
@@ -203,13 +209,27 @@ AC_SUBST([bindir_expanded])
### Output files
-AC_CONFIG_FILES([infrastructure/BoxPlatform.pm])
+AC_CONFIG_FILES([bin/bbackupd/bbackupd-config
+ bin/bbackupquery/makedocumentation.pl
+ bin/bbstored/bbstored-certs
+ bin/bbstored/bbstored-config
+ infrastructure/BoxPlatform.pm
+ infrastructure/makebuildenv.pl
+ infrastructure/makeparcels.pl
+ lib/common/makeexception.pl
+ lib/raidfile/raidfile-config
+ lib/server/makeprotocol.pl
+ runtest.pl
+ test/backupstorefix/testfiles/testbackupstorefix.pl
+ test/bbackupd/testfiles/extcheck1.pl
+ test/bbackupd/testfiles/extcheck2.pl
+ test/bbackupd/testfiles/notifyscript.pl])
AC_OUTPUT
# Configure the Box build system
echo
-perl ./infrastructure/makebuildenv.pl &&
- perl ./infrastructure/makeparcels.pl
+$PERL ./infrastructure/makebuildenv.pl &&
+ $PERL ./infrastructure/makeparcels.pl
# Write summary of important info
cat <<EOC