summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJames O'Gorman <james@netinertia.co.uk>2008-03-25 22:29:24 +0000
committerJames O'Gorman <james@netinertia.co.uk>2008-03-25 22:29:24 +0000
commitfc995b92cd73385800c0c9cff1c7f1231f8de532 (patch)
tree01b830a29766aaccd85cc226fc0a0c6d2a40d4cf /configure.ac
parenta5808325941f2eb8aaf2abf703c07a19ac93acc7 (diff)
Correct sysconfdir and localstatedir as they weren't doing what they were supposed to.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 00c0317c..f8390ec9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,10 +6,6 @@ AC_INIT([Box Backup], 0.11, [boxbackup@fluffy.co.uk])
AC_CONFIG_SRCDIR([lib/common/Box.h])
AC_CONFIG_HEADERS([lib/common/BoxConfig.h])
-# override default sysconfdir, for backwards compatibility
-test "$sysconfdir" = NONE && sysconfdir=/etc
-test "$localstatedir" = NONE && localstatedir=/var/run
-
touch install-sh
AC_CANONICAL_SYSTEM
test -s install-sh || rm install-sh
@@ -273,6 +269,10 @@ if test "x$enable_static_bin" = "xyes"; then
LIBS="-Wl,-Bstatic $LIBS -Wl,-Bdynamic"
fi
+# override default sysconfdir, for backwards compatibility
+test "$sysconfdir" = '${prefix}/etc' && sysconfdir=/etc
+test "$localstatedir" = '${prefix}/var' && localstatedir=/var
+
## Kludge to allow makeparcels.pl to use bindir. This is not a good long term
## solution because it prevents use of "make exec_prefix=/some/dir"
saved_prefix=$prefix