summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2006-01-07 23:35:52 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2006-01-07 23:35:52 +0000
commit625d588938d638ce72457305203e61e9f9ebc3b8 (patch)
tree79d1d3106306096838db67ff54b5d6809305a228 /configure.ac
parent4236badf30da3ebff007ad72d91fd10e32f5c345 (diff)
Fix raidfile intercept tests on 32 bit Linux with large file support.
Now intercept tests are never disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8cb0d945..3322cf91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,17 +132,13 @@ AC_CHECK_DECLS([XATTR_NOFOLLOW],,, [[#include <sys/xattr.h>]])
### Miscellaneous complicated feature checks
## Check for large file support active. AC_SYS_LARGEFILE has already worked
-## out how to enable it if necessary, we need to know if we've got it so we
-## can disable the raidfile intercepts
+## out how to enable it if necessary, we just use this to report to the user
AC_CACHE_CHECK([if we have large file support enabled], [have_large_file_support],
[AC_RUN_IFELSE([AC_LANG_PROGRAM([[$ac_includes_default]], [[
return sizeof(off_t)==4;
]])],
[have_large_file_support=yes], [have_large_file_support=no]
)])
-if test "x$have_large_file_support" = "xyes"; then
- AC_DEFINE([HAVE_LARGE_FILE_SUPPORT], 1, [Define to 1 large file support is in use])
-fi
## Find out how to do file locking
AC_CHECK_FUNCS([flock])