summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Ebourne <martin@ebourne.me.uk>2006-02-03 00:44:12 +0000
committerMartin Ebourne <martin@ebourne.me.uk>2006-02-03 00:44:12 +0000
commit20a736e41510ea3deb00e93541490a94d23cdb6c (patch)
treee7a611110c7d304b6ca0125ecdfc405db10d2ef6 /configure.ac
parenta5eaeaa9ff39a5568d9425ec57fd1af5dfe79c90 (diff)
Beef up configure checks for 64 bit endian swapping function.
NOTE: Needs testing on other platforms, especially BSD.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a9b820c2..4f2c7ea5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,9 +77,8 @@ AC_HEADER_DIRENT
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS([execinfo.h regex.h signal.h syslog.h time.h])
-AC_CHECK_HEADERS([asm/byteorder.h])
AC_CHECK_HEADERS([netinet/in.h])
-AC_CHECK_HEADERS([sys/endian.h sys/param.h sys/types.h sys/wait.h sys/xattr.h sys/time.h])
+AC_CHECK_HEADERS([sys/param.h sys/types.h sys/wait.h sys/xattr.h sys/time.h])
### Checks for typedefs, structures, and compiler characteristics.
@@ -109,6 +108,9 @@ AX_CHECK_DIRENT_D_TYPE
AC_SYS_LARGEFILE
AX_CHECK_LLONG_MINMAX
AX_CHECK_DEFINE_PRAGMA
+if test "x$ac_cv_c_bigendian" != "xyes"; then
+ AX_BSWAP64
+fi
if test "$target_os" != "mingw32"; then
AX_RANDOM_DEVICE
fi