summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2018-02-20 21:49:13 -0500
committerReinhard Tartler <siretart@tauware.de>2018-02-20 21:49:13 -0500
commitf28f88e5e72ba1499409047a9d6985eb312c0232 (patch)
treec9c267f18264b3dfe715a363935bb6ac20904492 /configure.ac
parente19a5db232e1ef90e9a02159d2fbd9707ffe4373 (diff)
parent6d7e9562e8485591a4888f1fc2d3c6c657dc7a01 (diff)
Merge tag 'BoxBackup-0.12.master.180102.6d7e956' into upstream
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 4 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index c5a05fe4..f9f481d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,9 @@
AC_PREREQ(2.59)
AC_INIT([Box Backup], 0.11, [boxbackup@boxbackup.org],[boxbackup])
AC_CONFIG_SRCDIR([lib/common/Box.h])
+AC_CONFIG_AUX_DIR([infrastructure])
AC_CONFIG_HEADERS([lib/common/BoxConfig.h])
+AC_CONFIG_SUBDIRS([qdbm])
touch install-sh
AC_CANONICAL_SYSTEM
@@ -93,7 +95,6 @@ AC_CONFIG_FILES([infrastructure/BoxPlatform.pm
test/bbackupd/testfiles/bbackupd-temploc.conf
])
AX_CONFIG_SCRIPTS([bin/bbackupd/bbackupd-config
- bin/bbackupquery/makedocumentation.pl
bin/bbstored/bbstored-certs
bin/bbstored/bbstored-config
contrib/debian/bbackupd
@@ -106,8 +107,8 @@ AX_CONFIG_SCRIPTS([bin/bbackupd/bbackupd-config
contrib/solaris/bbstored-smf-method
contrib/windows/installer/boxbackup.mpi
infrastructure/makebuildenv.pl
- infrastructure/makeparcels.pl
infrastructure/makedistribution.pl
+ lib/bbackupquery/makedocumentation.pl
lib/common/makeexception.pl
lib/raidfile/raidfile-config
lib/server/makeprotocol.pl
@@ -122,27 +123,11 @@ AC_OUTPUT
# Configure the Box build system
echo
-if ! $PERL ./infrastructure/makebuildenv.pl \
-|| ! $PERL ./infrastructure/makeparcels.pl; then
+if ! $PERL ./infrastructure/makebuildenv.pl; then
echo "Making infrastructure failed!"
exit 1
fi
-cat parcels.txt | sed -e 's/#.*//' | while read cmd subdir configure_args; do
- if test "$cmd" = "subdir"; then
- echo
- export CC CXX CFLAGS CXXFLAGS LDFLAGS LIBS
- args="$configure_args --target=$target_alias"
- echo "Configuring $subdir with: $args"
-
- cd $subdir
- if ! ./configure $args; then
- echo "Configuring $subdir with $args failed!" >&2
- exit 1
- fi
- fi
-done || exit $?
-
# Write summary of important info
tee config.log.features <<EOC
A summary of the build configuration is below. Box Backup will function