summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-07-26 15:02:50 +0000
committerChris Wilson <chris+github@qwirx.com>2008-07-26 15:02:50 +0000
commitf4d0141d29517ab7221b1deeee2924ff105206bc (patch)
tree979e805632ab3aa370ba0bbc0c7b2d649ba51712 /configure.ac
parent4d8f7a1372e7e5e893a2bcc87739538e51c93792 (diff)
Remove -rdynamic flag from mingw gcc which doesn't support it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index da407dc9..54157690 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,11 +20,16 @@ if test "x$ac_cv_cxx_exceptions" != "xyes" || \
test "x$ac_cv_cxx_namespaces" != "xyes"; then
AC_MSG_ERROR([[basic compile checks failed, the C++ compiler is broken]])
fi
+
if test "x$GXX" = "xyes"; then
# Use -Wall if we have gcc. This gives better warnings
AC_SUBST([CXXFLAGS_STRICT], ['-Wall -Wundef'])
- # Use -rdynamic if we have gcc. This is needed for backtrace
- AC_SUBST([LDADD_RDYNAMIC], ['-rdynamic'])
+
+ # Use -rdynamic if we have gcc, but not mingw. This is needed for backtrace
+ case $target_os in
+ mingw*) ;;
+ *) AC_SUBST([LDADD_RDYNAMIC], ['-rdynamic']) ;;
+ esac
fi
AC_PATH_PROG([PERL], [perl], [AC_MSG_ERROR([[perl executable was not found]])])