summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2014-12-26 23:16:32 +0000
committerChris Wilson <chris+github@qwirx.com>2014-12-26 23:16:32 +0000
commitf56c9ccf0a31c046b8c53abfabd5df06b97c22ce (patch)
treefcd5c581a91a747e3eeec43aa06b035ec3bfefbd /configure.ac
parentbedcb57939ac82910157e6b89f87a3b839b63ad7 (diff)
Use autoconf standard mechanism to configure qdbm subdirectory.
This ensures that all the right command-line options are passed to qdbm's configure script, and simplifies our configure script, and is more standard.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 1 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 6f0a8f7e..ebde6b69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,7 @@ AC_INIT([Box Backup], 0.11, [boxbackup@boxbackup.org],[boxbackup])
AC_CONFIG_SRCDIR([lib/common/Box.h])
AC_CONFIG_AUX_DIR([infrastructure])
AC_CONFIG_HEADERS([lib/common/BoxConfig.h])
+AC_CONFIG_SUBDIRS([qdbm])
touch install-sh
AC_CANONICAL_SYSTEM
@@ -129,21 +130,6 @@ if ! $PERL ./infrastructure/makebuildenv.pl \
exit 1
fi
-cat parcels.txt | sed -e 's/#.*//' | while read cmd subdir configure_args; do
- if test "$cmd" = "subdir"; then
- echo
- export CC CXX CFLAGS CXXFLAGS LDFLAGS LIBS
- args="$configure_args --host=$host_alias --build=$build_alias --target=$target_alias"
- echo "Configuring $subdir with: $args"
-
- cd $subdir
- if ! ./configure $args; then
- echo "Configuring $subdir with $args failed!" >&2
- exit 1
- fi
- fi
-done || exit $?
-
# Write summary of important info
tee config.log.features <<EOC
A summary of the build configuration is below. Box Backup will function