summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorReinhard Tartler <siretart@tauware.de>2009-03-31 16:25:00 +0200
committerReinhard Tartler <siretart@tauware.de>2009-03-31 16:25:00 +0200
commit44b120498762b986fa963dce3b18c81de88292e7 (patch)
tree0e6a97d196feb27e519f20b38a9fb0b916d27202 /debian/rules
parentde2e8f79c131aa1ab8c64a87cc9ef874f324d855 (diff)
cleanup debian/rules
create VERSION.txt for svn snapshots fix clean target for svn snapshots call bootstrap to create the configure script
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 9 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 68835913..929bd22a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,13 +20,13 @@ endif
configure: configure-stamp
configure-stamp:
dh_testdir
+ echo "0.11rc2+`cat .svnrevision`\nboxbackup" > VERSION.txt
+ sh -x ./bootstrap
./configure $(DEB_EXTRA_CONFIG_FLAGS) LDFLAGS="-Wl,--as-needed"
touch configure-stamp
build-stamp: configure-stamp
dh_testdir
- sh -x ./bootstrap
- sh ./configure --prefix=/usr
$(MAKE)
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
-./runtest.pl ALL
@@ -76,6 +76,12 @@ clean:
dh_testdir
dh_testroot
dh_clean build-stamp configure-stamp
+ echo "USE_SVN_VERSION\nboxbackup" > VERSION.txt
+ [ ! -f Makefile ] || make clean
+
+ rm -fr aclocal.m4 configure
+ rm -fr contrib/*/bbackupd contrib/*/bbstored
+ rm -fr lib/common/BoxConfig.h.in test/bbackupd/testfiles/bbackupd.conf
find . -name '*.o' | xargs --no-run-if-empty rm
find . -name '*.a' | xargs --no-run-if-empty rm
@@ -83,7 +89,6 @@ clean:
find . -name '_*' | xargs --no-run-if-empty rm
find . -name 'test-*.log' | xargs --no-run-if-empty rm
find . -name 'Makefile' | xargs --no-run-if-empty rm
- rm -f config.log config.status
# the test scripts do strange things here
# (directories without write permissions)
@@ -92,8 +97,7 @@ clean:
dh_clean config.log config.status
dh_clean documentation/instguide.pdf documentation/adminguide.pdf
- [ ! -f Makefile ] || $(MAKE) distclean
- [ ! -f Makefile ] || $(MAKE) clean
+
dh_clean $(GENERATED_FILES)
install: DH_OPTIONS=