summaryrefslogtreecommitdiff
path: root/documentation/boxbackup/Makefile
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-01-02 13:36:19 +0000
committerChris Wilson <chris+github@qwirx.com>2008-01-02 13:36:19 +0000
commit20f0ac48ee3a75205b3e75018a80535f5283f1e5 (patch)
tree67dc915036b694f5d8891c2eb5d602e60788c856 /documentation/boxbackup/Makefile
parent16478e240c659a4fc2156ee36171e84867767a84 (diff)
Add a docs target that builds the docs but without making a dockit.
Don't fail if box-html/images already exists when making docs.
Diffstat (limited to 'documentation/boxbackup/Makefile')
-rw-r--r--documentation/boxbackup/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/documentation/boxbackup/Makefile b/documentation/boxbackup/Makefile
index ea795710..aefa3ee2 100644
--- a/documentation/boxbackup/Makefile
+++ b/documentation/boxbackup/Makefile
@@ -10,7 +10,12 @@ HTMLPREFIX=box-html
VPATH= adminguide
.SUFFIXES: .html .xml
-all: adminguide instguide manpages
+all: docs
+
+docs: instguide adminguide manpages
+ mkdir -p $(HTMLPREFIX)/images
+ cp html/images/*.png $(HTMLPREFIX)/images/.
+ cp html/*.css $(HTMLPREFIX)/.
adminguide: $(HTMLPREFIX)/adminguide/index.html
@@ -49,10 +54,7 @@ man-html: bbackupquery.html bbackupctl.html bbstoreaccounts.html bbstored-config
mv $@ man-pages/.
gzip -f -9 man-pages/$@
-dockit: instguide adminguide manpages
- mkdir $(HTMLPREFIX)/images
- cp html/images/*.png $(HTMLPREFIX)/images/.
- cp html/*.css $(HTMLPREFIX)/.
+dockit: clean docs
tar zcf documentation-kit-0.10.tar.gz $(HTMLPREFIX)/
clean: