summaryrefslogtreecommitdiff
path: root/documentation/boxbackup/Makefile
diff options
context:
space:
mode:
authorPer Reedtz Thomsen <pthomsen@reedtz.com>2006-03-30 21:04:14 +0000
committerPer Reedtz Thomsen <pthomsen@reedtz.com>2006-03-30 21:04:14 +0000
commit2b4c86b2700d20a4c1734e86f5133a2ab4acc351 (patch)
treeb72505de8371764e401508605f9f60f6a3f7ebca /documentation/boxbackup/Makefile
parent70504e42d2d79c40054d8aa6cb7d4337a3a73207 (diff)
Changed bb-book.xsl to point to the correct places in the directory structure.
Admin Guide now contains all exception codes. See below. generate_except_xml.pl generates a DocBook Appendix with all exceptions from ExceptionCodes.txt. That is then included in the Admin Guide. Makefile updated to generate ExceptionCodes.xml, and the dockit.
Diffstat (limited to 'documentation/boxbackup/Makefile')
-rw-r--r--documentation/boxbackup/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/documentation/boxbackup/Makefile b/documentation/boxbackup/Makefile
index a3235ec5..50374978 100644
--- a/documentation/boxbackup/Makefile
+++ b/documentation/boxbackup/Makefile
@@ -8,21 +8,24 @@ MANXSL=bb-man.xsl
VPATH= adminguide
.SUFFIXES: .html .xml
-all: adminguide instguide
+all: adminguide instguide
-adminguide: adminguide/index.html
+adminguide: adminguide/index.html
-adminguide/index.html: adminguide.xml
+adminguide/index.html: adminguide.xml ExceptionCodes.xml bb-book.xsl
# docname=`echo $@ | sed -e 's/\/index.html//'`
$(DBPROC) -o adminguide/ $(BOOKXSL) adminguide.xml
-instguide: instguide/index.html
+instguide: instguide/index.html bb-book.xsl
-instguide/index.html: instguide.xml
+instguide/index.html: instguide.xml bb-book.xsl
$(DBPROC) -o instguide/ $(BOOKXSL) instguide.xml
+ExceptionCodes.xml: ../../ExceptionCodes.txt
+ perl ./generate_except_xml.pl
+
dockit: instguide adminguide
- tar zcf documentation-kit-0.10.tar.gz images/ instguide/ adminguide/
+ tar zcf documentation-kit-0.10.tar.gz html/ instguide/ adminguide/
clean:
rm -rf ./instguide/