summaryrefslogtreecommitdiff
path: root/documentation
diff options
context:
space:
mode:
authorJames O'Gorman <james@netinertia.co.uk>2008-09-30 23:27:06 +0000
committerJames O'Gorman <james@netinertia.co.uk>2008-09-30 23:27:06 +0000
commit1a228e2db35b572b4ec924dc144b8997ea42ce45 (patch)
treef58b5039d082bd82fc194990e0c23ce76f40b199 /documentation
parent2c11ab06e347cbd08469c735cd14f39ea6cbdaa3 (diff)
Update documentation Makefile to include a few more man pages and to make the man page stylesheet dynamic (whether it downloads the XSL stylesheet from the Internet or uses a local copy).
Diffstat (limited to 'documentation')
-rw-r--r--documentation/Makefile27
-rw-r--r--documentation/bb-man.xsl.tmpl (renamed from documentation/bb-man.xsl)2
2 files changed, 22 insertions, 7 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index 4f945575..7929f613 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -8,6 +8,14 @@ NOCHUNKBOOKXSL=bb-nochunk-book.xsl
MANXSL=bb-man.xsl
HTMLPREFIX=box-html
VPATH= adminguide
+# If your OS declares a system make variable, add a .elif statement here
+# with the path to the locally-installed DocBook stylesheet
+.if .FreeBSD
+# Requires textproc/docbook-xsl port installed
+DOCBOOK=file:///usr/local/share/xsl/docbook/manpages/docbook.xsl
+.else
+DOCBOOK=http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
+.endif
.SUFFIXES: .html .xml .1 .5 .8
all: docs
@@ -31,7 +39,10 @@ $(HTMLPREFIX)/instguide/index.html: instguide.xml $(BOOKXSL)
ExceptionCodes.xml: ../ExceptionCodes.txt
perl ./generate_except_xml.pl
-manpages: man-dirs man-nroff man-html
+manpages: $(MANXSL) man-dirs man-nroff man-html
+
+$(MANXSL): $(MANXSL).tmpl
+ @sed -e 's,%%DOCBOOK%%,$(DOCBOOK),' $(MANXSL).tmpl > $(MANXSL)
man-dirs: man-pages/.there $(HTMLPREFIX)/man-html/.there
@@ -41,17 +52,21 @@ $(HTMLPREFIX)/man-html/.there:
man-pages/.there:
if [ ! -d man-pages ]; then mkdir man-pages; touch man-pages/.there; fi
-man-nroff: bbackupquery.8 bbackupctl.8 bbstoreaccounts.8 bbstored-config.8 \
- raidfile-config.8 bbstored-certs.8
+man-nroff: bbackupd.8 bbackupd-config.8 bbackupctl.8 bbackupquery.8 \
+ bbstored.8 bbstored-config.8 bbstoreaccounts.8 bbstored-certs.8 \
+ raidfile-config.8 \
+ bbackupd.conf.5 bbstored.conf.5 raidfile.conf.5
-man-html: bbackupquery.html bbackupctl.html bbstoreaccounts.html \
- bbstored-config.html raidfile-config.html bbstored-certs.html
+man-html: bbackupd.html bbackupd-config.html bbackupctl.html bbackupquery.html \
+ bbstored.html bbstored-config.html bbstoreaccounts.html bbstored-certs.html \
+ raidfile-config.html \
+ bbackupd.conf.html bbstored.conf.html raidfile.conf.html
.xml.html:
$(DBPROC) -o $@ $(NOCHUNKBOOKXSL) $<
cp $@ $(HTMLPREFIX)/man-html/.
-.xml.8:
+.xml.8 .xml.5:
$(DBPROC) -o $@ $(MANXSL) $<
cp $@ man-pages/
rm -f man-pages/$@.gz
diff --git a/documentation/bb-man.xsl b/documentation/bb-man.xsl.tmpl
index 24d99381..e20eedd5 100644
--- a/documentation/bb-man.xsl
+++ b/documentation/bb-man.xsl.tmpl
@@ -2,7 +2,7 @@
<xsl:stylesheet
xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
-<xsl:import href="http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"/>
+<xsl:import href="%%DOCBOOK%%"/>
<xsl:param name="chunk.section.depth" select="'0'"/>