summaryrefslogtreecommitdiff
path: root/documentation
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2008-04-28 23:46:41 +0000
committerChris Wilson <chris+github@qwirx.com>2008-04-28 23:46:41 +0000
commit459434a0aa643112e1503bf0519a81a94fe00a65 (patch)
tree57dbcdfd5e39aacc29edaf43848dd85b94a84f54 /documentation
parent084595644e923f03d311c5a060b56b9b6c70f60e (diff)
Fix Makefile for BSD (and hopefully any POSIX) make.
Diffstat (limited to 'documentation')
-rw-r--r--documentation/Makefile41
1 files changed, 29 insertions, 12 deletions
diff --git a/documentation/Makefile b/documentation/Makefile
index aefa3ee2..02f1de31 100644
--- a/documentation/Makefile
+++ b/documentation/Makefile
@@ -2,13 +2,13 @@
# Process DocBook to HTML
-DBPROC=/usr/bin/xsltproc
+DBPROC=xsltproc
BOOKXSL=bb-book.xsl
NOCHUNKBOOKXSL=bb-nochunk-book.xsl
MANXSL=bb-man.xsl
HTMLPREFIX=box-html
VPATH= adminguide
-.SUFFIXES: .html .xml
+.SUFFIXES: .html .xml .1 .5 .8
all: docs
@@ -28,7 +28,7 @@ instguide: $(HTMLPREFIX)/instguide/index.html
$(HTMLPREFIX)/instguide/index.html: instguide.xml $(BOOKXSL)
$(DBPROC) -o $(HTMLPREFIX)/instguide/ $(BOOKXSL) instguide.xml
-ExceptionCodes.xml: ../../ExceptionCodes.txt
+ExceptionCodes.xml: ../ExceptionCodes.txt
perl ./generate_except_xml.pl
manpages: man-dirs man-nroff man-html
@@ -41,18 +41,35 @@ $(HTMLPREFIX)/man-html/.there:
man-pages/.there:
if [ ! -d man-pages ]; then mkdir man-pages; touch man-pages/.there; fi
-man-nroff: bbackupquery.1 bbackupctl.1 bbstoreaccounts.1 bbstored-config.1 raidfile-config.1 bbstored-certs.1
+man-nroff: bbackupquery.8 bbackupctl.8 bbstoreaccounts.8 bbstored-config.8 \
+ raidfile-config.8 bbstored-certs.8
-man-html: bbackupquery.html bbackupctl.html bbstoreaccounts.html bbstored-config.html raidfile-config.html bbstored-certs.html
+man-html: bbackupquery.html bbackupctl.html bbstoreaccounts.html \
+ bbstored-config.html raidfile-config.html bbstored-certs.html
-%.html: %.xml
+# for BSD make:
+.xml.html:
$(DBPROC) -o $@ $(NOCHUNKBOOKXSL) $<
- mv $@ $(HTMLPREFIX)/man-html/.
-
-%.1: %.xml
- $(DBPROC) -o $@ $(MANXSL) $<
- mv $@ man-pages/.
- gzip -f -9 man-pages/$@
+ cp $@ $(HTMLPREFIX)/man-html/.
+
+# for GNU make:
+#%.html: %.xml
+# $(DBPROC) -o $@ $(NOCHUNKBOOKXSL) $<
+# mv $@ $(HTMLPREFIX)/man-html/.
+
+# for BSD make:
+.xml.8:
+ $(DBPROC) -o $(.TARGET) $(MANXSL) $(.IMPSRC)
+ cp $(.TARGET) man-pages/
+ rm -f man-pages/$(.TARGET).gz
+ gzip -f -9 man-pages/$(.TARGET)
+
+# for GNU make:
+#%.8: %.xml
+# $(DBPROC) -o $@ $(MANXSL) $<
+# cp $@ man-pages/
+# rm -f man-pages/$@.gz
+# gzip -f -9 man-pages/$@
dockit: clean docs
tar zcf documentation-kit-0.10.tar.gz $(HTMLPREFIX)/