summaryrefslogtreecommitdiff
path: root/documentation
diff options
context:
space:
mode:
authorPer Reedtz Thomsen <pthomsen@reedtz.com>2006-03-29 23:04:26 +0000
committerPer Reedtz Thomsen <pthomsen@reedtz.com>2006-03-29 23:04:26 +0000
commit70504e42d2d79c40054d8aa6cb7d4337a3a73207 (patch)
tree208b1c4cd557ea789387825085bad627f66e1b70 /documentation
parentf38da1d0a58251e89ae24723c8217b2c2042dfbc (diff)
Added XSL customization layer, and Makefile.
The Makefile is pretty simple, and doesn't integrate into the full build. At least not at this time.
Diffstat (limited to 'documentation')
-rw-r--r--documentation/boxbackup/Makefile36
-rw-r--r--documentation/boxbackup/bb-book.xsl17
2 files changed, 53 insertions, 0 deletions
diff --git a/documentation/boxbackup/Makefile b/documentation/boxbackup/Makefile
new file mode 100644
index 00000000..a3235ec5
--- /dev/null
+++ b/documentation/boxbackup/Makefile
@@ -0,0 +1,36 @@
+
+
+# Process DocBook to HTML
+
+DBPROC=/usr/bin/xsltproc
+BOOKXSL=bb-book.xsl
+MANXSL=bb-man.xsl
+VPATH= adminguide
+.SUFFIXES: .html .xml
+
+all: adminguide instguide
+
+adminguide: adminguide/index.html
+
+adminguide/index.html: adminguide.xml
+ # docname=`echo $@ | sed -e 's/\/index.html//'`
+ $(DBPROC) -o adminguide/ $(BOOKXSL) adminguide.xml
+
+instguide: instguide/index.html
+
+instguide/index.html: instguide.xml
+ $(DBPROC) -o instguide/ $(BOOKXSL) instguide.xml
+
+dockit: instguide adminguide
+ tar zcf documentation-kit-0.10.tar.gz images/ instguide/ adminguide/
+
+clean:
+ rm -rf ./instguide/
+ rm -rf ./adminguide/
+ rm documentation-kit-0.10.tar.gz
+
+
+# %.html: %.xml
+# $(DBPROC) -o $@ $(BOOKXSL) $@.xml
+
+
diff --git a/documentation/boxbackup/bb-book.xsl b/documentation/boxbackup/bb-book.xsl
new file mode 100644
index 00000000..183c74aa
--- /dev/null
+++ b/documentation/boxbackup/bb-book.xsl
@@ -0,0 +1,17 @@
+<?xml version='1.0'?>
+<xsl:stylesheet
+ xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
+
+<xsl:import href="http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl"/>
+
+<xsl:param name="html.stylesheet" select="'bbdoc.css'"/>
+<xsl:param name="chunk.section.depth" select="'0'"/>
+<xsl:template name="user.header.navigation">
+<div id="header">
+<div id="logo">
+<img src="images/bblogo.png" alt="logo" height="65" width="331" border="0" vspace="5" align="middle" /> <img src="images/stepahead.png" alt="a step ahead in data security" width="182" height="11" hspace="10" vspace="20" border="0" align="middle" /></div>
+</div>
+</xsl:template>
+
+
+</xsl:stylesheet>