summaryrefslogtreecommitdiff
path: root/documentation
diff options
context:
space:
mode:
authorPer Reedtz Thomsen <pthomsen@reedtz.com>2006-03-31 01:14:47 +0000
committerPer Reedtz Thomsen <pthomsen@reedtz.com>2006-03-31 01:14:47 +0000
commitfaabc2a9282b7b5b8c9b8aeb4556e87fe5f7b6b7 (patch)
treee124a23d29ab56c0f7e654f6befbbd369bd79437 /documentation
parent8c578209d552ba114e520b9a712c950df4324e11 (diff)
generate_except_xml.pl: closing the files at the end of the script.
Makefile: changing to use a macro everywhere for bb-book.xsl
Diffstat (limited to 'documentation')
-rw-r--r--documentation/boxbackup/Makefile7
-rw-r--r--documentation/boxbackup/generate_except_xml.pl3
2 files changed, 7 insertions, 3 deletions
diff --git a/documentation/boxbackup/Makefile b/documentation/boxbackup/Makefile
index 50374978..36016d73 100644
--- a/documentation/boxbackup/Makefile
+++ b/documentation/boxbackup/Makefile
@@ -12,13 +12,13 @@ all: adminguide instguide
adminguide: adminguide/index.html
-adminguide/index.html: adminguide.xml ExceptionCodes.xml bb-book.xsl
+adminguide/index.html: adminguide.xml ExceptionCodes.xml $(BOOKXSL)
# docname=`echo $@ | sed -e 's/\/index.html//'`
$(DBPROC) -o adminguide/ $(BOOKXSL) adminguide.xml
-instguide: instguide/index.html bb-book.xsl
+instguide: instguide/index.html
-instguide/index.html: instguide.xml bb-book.xsl
+instguide/index.html: instguide.xml $(BOOKXSL)
$(DBPROC) -o instguide/ $(BOOKXSL) instguide.xml
ExceptionCodes.xml: ../../ExceptionCodes.txt
@@ -30,6 +30,7 @@ dockit: instguide adminguide
clean:
rm -rf ./instguide/
rm -rf ./adminguide/
+ rm ExceptionCodes.xml
rm documentation-kit-0.10.tar.gz
diff --git a/documentation/boxbackup/generate_except_xml.pl b/documentation/boxbackup/generate_except_xml.pl
index 1c6f9152..9046d5cf 100644
--- a/documentation/boxbackup/generate_except_xml.pl
+++ b/documentation/boxbackup/generate_except_xml.pl
@@ -68,4 +68,7 @@ EOD
}
print DOCBOOK "</appendix>\n";
+
+close EXCEPT;
+close DOCBOOK;
\ No newline at end of file