summaryrefslogtreecommitdiff
path: root/infrastructure/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorDebian QA Group <packages@qa.debian.org>2018-02-28 08:31:56 -0500
committerReinhard Tartler <siretart@tauware.de>2018-02-28 08:31:56 -0500
commitfb9c8bb7fa9d0531322b282e3e627ca43a8bfc51 (patch)
treef11a6d242821917340d228044cc9d2d446cef84c /infrastructure/cmake/CMakeLists.txt
parentac99c8589f0e74893cea3822c1511b322530dfc7 (diff)
revert_to_openssl_1.0
commit bc48bec97b65534966da74a07ed3edb3f13f6263 (github/revert_openssl_1_1) Author: Chris Wilson <chris+github@qwirx.com> Date: Sun Feb 25 08:18:34 2018 +0000 Revert "Add support for OpenSSL 1.1 and replace deprecated function calls" Until shown to be safe. See message from Johann Glaser to the mailing list. This reverts commit 85e7efc3fa0477f60318d2cd2144503a9ea8feb9. Gbp-Pq: Name 01-revert_to_openssl_1.0.diff
Diffstat (limited to 'infrastructure/cmake/CMakeLists.txt')
-rw-r--r--infrastructure/cmake/CMakeLists.txt21
1 files changed, 1 insertions, 20 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 65f59eb8..25015452 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -407,26 +407,7 @@ else()
endif()
# Link to OpenSSL
-# Workaround for incorrect library suffixes searched by FindOpenSSL:
-# https://gitlab.kitware.com/cmake/cmake/issues/17604
-if(WIN32 AND MSVC)
- find_package(OpenSSL)
- set(OPENSSL_SSL_LIBRARY ${SSL_EAY_RELEASE})
- set(OPENSSL_CRYPTO_LIBRARY ${LIB_EAY_RELEASE})
- set(OPENSSL_LIBRARIES ${OPENSSL_SSL_LIBRARY} ${OPENSSL_CRYPTO_LIBRARY} crypt32)
- find_package_handle_standard_args(OpenSSL
- REQUIRED_VARS
- OPENSSL_SSL_LIBRARY
- OPENSSL_CRYPTO_LIBRARY
- OPENSSL_INCLUDE_DIR
- VERSION_VAR
- OPENSSL_VERSION
- FAIL_MESSAGE
- "Could NOT find OpenSSL, try to set the path to OpenSSL root folder in the system variable OPENSSL_ROOT_DIR"
- )
-else()
- find_package(OpenSSL REQUIRED)
-endif()
+find_package(OpenSSL REQUIRED)
include_directories(${OPENSSL_INCLUDE_DIR})
target_link_libraries(lib_crypto PUBLIC ${OPENSSL_LIBRARIES})