summaryrefslogtreecommitdiff
path: root/infrastructure/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Wilson <chris+github@qwirx.com>2015-12-24 20:26:16 +0000
committerChris Wilson <chris+github@qwirx.com>2015-12-24 20:26:16 +0000
commit560966d7f4ec11962273eb7579f88d5f7e744298 (patch)
treeb89a4683e7692ff5ee2074baadd47131c244c5e2 /infrastructure/cmake/CMakeLists.txt
parent0419969afa44e87cf7eaa1cb23169bf35c169c4b (diff)
Run release tests, not debug tests, in the release configuration.
Diffstat (limited to 'infrastructure/cmake/CMakeLists.txt')
-rw-r--r--infrastructure/cmake/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/infrastructure/cmake/CMakeLists.txt b/infrastructure/cmake/CMakeLists.txt
index 79551168..4a5d6426 100644
--- a/infrastructure/cmake/CMakeLists.txt
+++ b/infrastructure/cmake/CMakeLists.txt
@@ -195,7 +195,8 @@ foreach(module_dep
add_executable(${module_name} ${module_files}
"${module_path}/_main.cpp")
add_test(NAME ${test_name}
- COMMAND ${PERL_EXECUTABLE} ${base_dir}/runtest.pl ${test_name})
+ COMMAND ${PERL_EXECUTABLE} ${base_dir}/runtest.pl.in ${test_name}
+ ${CMAKE_BUILD_TYPE})
elseif(module_name MATCHES "^(lib_.*|qdbm)$")
if(DEBUG)
message(STATUS "add library '${module_name}': '${module_files}'")